Download it now!
Bug 125526 - Droid Serif installed but not showing in Cyrillics
Summary: Droid Serif installed but not showing in Cyrillics
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-05-27 15:54 UTC by Branko
Modified: 2019-06-03 16:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Droid Serif showing Cyrillics only when italicized (33.62 KB, image/png)
2019-05-27 15:55 UTC, Branko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Branko 2019-05-27 15:54:10 UTC
Description:
There is a bug with rendering Cyrillic with the Droid fonts in Libreoffice (I tried Writer and Impress), i.e. they don't show at all (image in attach). In Droid Sans Cyrillics doesn't show up at all, and in Droid Serif it only shows up when italic. For Droid Sans Mono it works fine.

Other software on my computer (Calligra) works fine.

Steps to Reproduce:
1.Write some Cyrillics in Droid Sans/Serif


Actual Results:
you can't see the text

Expected Results:
you can see the text


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.3.2
Build ID: 6.2.3-2
CPU threads: 8; OS: Linux 4.19; UI render: GL; VCL: kde5; 
Locale: en-US (mk_MK.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Branko 2019-05-27 15:55:57 UTC
Created attachment 151705 [details]
Droid Serif showing Cyrillics only when italicized
Comment 2 Roman Kuznetsov 2019-05-27 17:19:34 UTC
Branko, what Linux distro do you use?
Do you have enabled OpenGL in LibreOffice? Check it in Tools->Options dialog in LibreOffice->View page.
Can you try install LibreOffice from official site of TDF ?

https://www.libreoffice.org/donate/dl/deb-x86_64/6.2.4/ru/LibreOffice_6.2.4_Linux_x86-64_deb.tar.gz  for deb-packages

or 

https://www.libreoffice.org/donate/dl/rpm-x86_64/6.2.4/ru/LibreOffice_6.2.4_Linux_x86-64_rpm.tar.gz for rpm-packages

I can't repro it in windows build

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ccf3a0600ee902390ad6112ecf28223078bdd2db
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-13_03:08:59
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 3 Branko 2019-05-27 17:28:40 UTC
(In reply to Roman Kuznetsov from comment #2)
> Branko, what Linux distro do you use?
> Do you have enabled OpenGL in LibreOffice? Check it in Tools->Options dialog
> in LibreOffice->View page.
> Can you try install LibreOffice from official site of TDF ?
> 
> https://www.libreoffice.org/donate/dl/deb-x86_64/6.2.4/ru/LibreOffice_6.2.
> 4_Linux_x86-64_deb.tar.gz  for deb-packages
> 
> or 
> 
> https://www.libreoffice.org/donate/dl/rpm-x86_64/6.2.4/ru/LibreOffice_6.2.
> 4_Linux_x86-64_rpm.tar.gz for rpm-packages
> 
> I can't repro it in windows build
> 
> Version: 6.3.0.0.alpha0+ (x64)
> Build ID: ccf3a0600ee902390ad6112ecf28223078bdd2db
> CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
> TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-13_03:08:59
> Locale: ru-RU (ru_RU); UI-Language: en-US
> Calc: threaded

Privet Roman,

I'm using Manjaro with KDE. I've tried both with OpenGL and without and the issue remains. I'll try the official builds and tell you what happens.

Cheers
Branko
Comment 4 QA Administrators 2019-05-28 02:48:10 UTC Comment hidden (obsolete)
Comment 5 Vera Blagoveschenskaya 2019-05-28 06:05:19 UTC
Just FYI
Can't reproduce this for 6.2.5.0.0+, 6.3.0.0.alpha1+

Version: 6.2.5.0.0+
Build ID: 23ccf16e9e86ecc64367f41f4df695d0a6926d72
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-05-21_15:11:03
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.3.0.0.alpha1+
Build ID: 40e2a0d7039eee9c5377996da3949680903e1016
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-22_13:55:35
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Branko 2019-05-28 07:43:28 UTC
I just upgraded to 
Version: 6.2.4.2.0+
Build ID: 6.2.4-1

from Manjaro's libreoffice-fresh and the problem persists.

I'll try 6.2.5 next
Comment 7 Jan-Marek Glogowski 2019-06-01 07:25:25 UTC
What happens if you highlight the text?
I guess it's still invisible, but who knows.

If you save this as a document and load it, is it still invisible?

What happens if you export it as a PDF and open that?

What happens if you start LO from the terminal with "SAL_USE_VCLPLUGIN=qt5 soffice"?
I don't recommend that for normal use - too buggy, just to get some data point.

You have an interesting locale setting: en-US (mk_MK.UTF-8). So the text is expected to be in English?

Please create and attach a sample odt document, which shows the error.

And then reset the bug to UNCONFIRMED.

Thanks.
Comment 8 Branko 2019-06-03 16:35:34 UTC
Ok, today there seems to be no problem with the Droid fonts in the document or any other document. I can't reproduce it anymore. It's really strange as I think I did not do any upgrades.

The locale is English because I prefer the English menus (not to get lost in translation) and the default language for my documents is Macedonian.

Thanks for your help and keep up the good work!