Download it now!
Bug 125555 - FILESAVE DOC: Bookmark names, Cross and field references shortened if 40 chars long or corrupted if the target is a non-ASCII bookmark
Summary: FILESAVE DOC: Bookmark names, Cross and field references shortened if 40 char...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields-Cross-Reference DOC-Character DOC-Fields
  Show dependency treegraph
 
Reported: 2019-05-28 13:53 UTC by Timur
Modified: 2019-07-03 13:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
doc file (13.50 KB, application/msword)
2019-07-02 16:28 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2019-05-28 13:53:25 UTC
This is DOC bug report for issues Bug 113483 and Bug 125298 resolved in LO master 6.3+ for DOCX.
Steps: 
https://bugs.documentfoundation.org/show_bug.cgi?id=113483#c9
https://bugs.documentfoundation.org/show_bug.cgi?id=125298#c0

Even if DOC is obsolete to DOCX, these should be resolved. Reported together.
Comment 1 Usama 2019-06-16 03:57:41 UTC
Hello Timur,
Seems fixed in 
Version: 6.3.0.0.alpha1+
Build ID: 77ae0abe21f672cf4b7d2e069f1d40d20edc49a7
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-31_15:33:33
Locale: en-GB (en_GB.utf8); UI-Language: en-US
Calc: threaded

Should we close it as VERIFIED FIXED as well?
Comment 2 Timur 2019-06-17 08:21:32 UTC
Fixed is DOCX and this one is for DOC. Did you test both?
Comment 3 Dieter 2019-06-18 11:49:42 UTC
cc: Adam Kovacs, because he fixed bug 113483 and bug 125298
Comment 4 Timur 2019-07-02 10:58:18 UTC
Dieter, Xisco, what is needed is to reproduce and confirm the bug with DOC as different from resolved DOCX.
Comment 5 raal 2019-07-02 16:28:38 UTC
Created attachment 152514 [details]
doc file

works for me with Version: 6.4.0.0.alpha0+
Build ID: 9fbedb7929936a45967ae49bc15b985f95e2ebd3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: cs-CZ (cs_CZ.UTF-8); UI-Language: en-US

Timur, can you retest? Thanks
Comment 6 Timur 2019-07-03 10:53:48 UTC
Looks like you are right. DOC seems resolved in the meantime. Thanks to fixers and testers. 

But I see another problem now, last cross referenced text from DOC saved in LO is visible in LO but not in MSO. 
That's an earlier bug so I'll search and report separately. 
Wisdom is: when it's about MS formats, always also test both LO and MSO.