Download it now!
Bug 125610 - More Characters button is unreadable on macOS
Summary: More Characters button is unreadable on macOS
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Mac OS X (All)
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.4.0 target:6.3.2
Keywords: bibisected, bisected, regression
: 125795 127302 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-31 12:39 UTC by Xisco Faulí
Modified: 2019-09-05 03:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (51.87 KB, image/png)
2019-05-31 12:41 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-05-31 12:39:32 UTC
Steps to reproduce:
1. Open writer
2. click on Insert Special Characters on the toolbar

-> See screenshot

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: e575a5e8f89beb3ce1df5a1d83edc0f9d1d8ac43
CPU threads: 8; OS: Mac OS X 10.14.2; UI render: default; VCL: osx; 
Locale: en-US (en_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-05-31 12:41:28 UTC
Created attachment 151806 [details]
screenshot
Comment 2 Xisco Faulí 2019-05-31 12:43:07 UTC
Regression introduced by:

author	Andrew Hyatt <andrewrhyatt@icloud.com>	2019-05-02 14:33:12 -0400
committer	Tor Lillqvist <tml@collabora.com>	2019-05-03 12:14:36 +0200
commit	89775fd396e413daaf0e71710211075450bdc0ed (patch)
tree	9fe17610e0a4e96e627e4aa3c97fd8ee1b4956f9
parent	b69bc0facc6e0fbc2006125e656b82a7c2556203 (diff)
tdf#125088 Make button text white for blue buttons on macOS

Bisected with: 6.3-mac

Adding Cc: to Andrew Hyatt
Comment 3 Xisco Faulí 2019-09-04 14:02:15 UTC
*** Bug 127302 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2019-09-04 14:21:02 UTC
*** Bug 125795 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2019-09-04 14:25:36 UTC
Reverting patch: https://gerrit.libreoffice.org/#/c/78605/
Comment 6 Commit Notification 2019-09-05 03:03:30 UTC
Xisco Faulí committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ebd7af9aebb5b76255aa299dd8047cb4266215a4%5E%21

tdf#125610: Revert "tdf#125088 Make button text white for blue buttons on macOS"

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-09-05 03:09:44 UTC
Xisco Faulí committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/ab5da884b16aa54aab8e9773a6e8dbf24e752c36%5E%21

tdf#125610: Revert "tdf#125088 Make button text white for blue buttons on macOS"

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.