Bug Hunting Session
Bug 125617 - 'problem with fonts' enhanced instead of solved in alpha1
Summary: 'problem with fonts' enhanced instead of solved in alpha1
Status: RESOLVED DUPLICATE of bug 125054
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2019-06-01 11:16 UTC by b.
Modified: 2019-06-10 20:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
font_problem_with_6_3_alpha (47.56 KB, image/jpeg)
2019-06-01 12:03 UTC, b.
Details
font_problem_with_6_3_alpha (8.24 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-06-01 12:10 UTC, b.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description b. 2019-06-01 11:16:08 UTC
Description:
there was a problem with fonts in prior alpha releases, it changed while editing from e.g. Arial to Liberation Sans, in the lastest alpa - see below - it's showing plenty - but not all! - cells in Liberation Sans, and! they are resistible against changing. 

to triage i created a new sheet, keyed in 'Guc' in A1, it is shown in Liberation Sans, but the white choosebox say's 'Arial', i can! change the assigned font in the formula bar (highlighting the word and assigning Arial), but not! inside the cell, and despite being 'named' Arial and the formatting 'works' on the formula bar the word in the cell is still shown in Liberation Sans ... funny. 

Steps to Reproduce:
1. see above, 
2.
3.

Actual Results:
cell content shown in wrong font, 

Expected Results:
cell content shown in assigned font, 


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha1 (x64)
Build ID: 547edd20e527fb02900f6174973770d26306e2e7
CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc:
Comment 1 m.a.riosv 2019-06-01 11:27:39 UTC
I can't repro.
Plesse test with a clean profile Menu/Help/Restart in Safe Mode.
Comment 2 b. 2019-06-01 12:03:51 UTC
Created attachment 151828 [details]
font_problem_with_6_3_alpha

@m.a.riosv: tried 'restart in safe mode', no change, see attached screenshot and file with error in next comment. 
cell A2 is Liberation Sans by choose, A1 by fault.
Comment 3 b. 2019-06-01 12:10:56 UTC
Created attachment 151829 [details]
font_problem_with_6_3_alpha

file with erroneous font in cell A1, older versions of calc show better fitting fonts, 

other 'problem', the font chosen for A2 is Liberation Sans, shown is something else, might be Liberation Serif, 

if no repo System might make the difference, win7 pro (x64),
Comment 4 Jacques Guilleron 2019-06-01 16:59:27 UTC
Hi b., Miguel,

I reproduce too with
6.3.0.0.alpha1
Build ID: 547edd20e527fb02900f6174973770d26306e2e7
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: en-US (fr_FR); UI-Language: en-US
Calc: CL
but not with
LO  6.3.0.0.alpha0+
Build ID: f6a64f9bdce16cc18bb086b0de894fba7e1538c3
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: en-US (fr_FR); UI-Language: en-US
Calc: CL
Whatever the font you choose, it will be modified into Liberation Serif when you
will leave the cell.

Jacques
Comment 5 raal 2019-06-03 11:41:59 UTC
No repro with Version: 6.3.0.0.alpha1+
Build ID: aa687b22991e6c674b1d8653d52fbe9a50080174
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Steps: open file;change A1 font; leave cell - the font is changed
Comment 6 Xisco Faulí 2019-06-10 20:16:18 UTC
This is a duplicate of bug 125054.
Please try with recent master build...

*** This bug has been marked as a duplicate of bug 125054 ***