Bug Hunting Session
Bug 125638 - Table not proper displayed after accepting all changes until reload => pages disappear
Summary: Table not proper displayed after accepting all changes until reload => pages ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 125639 (view as bug list)
Depends on:
Blocks: Track-Changes Writer-Tables
  Show dependency treegraph
 
Reported: 2019-06-02 13:28 UTC by Telesto
Modified: 2019-06-11 12:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-06-02 13:28:38 UTC
Description:
Disappearing pages after accepting all changes (tracking changes)

Steps to Reproduce:
1. Open attachment 147138 [details]
2. CTRL+A + CTRL+C
3. CTRL+N
4. CTRL+SHIFT+C (Enable tracking changes) (for the new document)
5. CTRL+V
6. Accept all changes -> 3 pages shown
7. Save & reload -> Proper page count 

Actual Results:
Only 3 pages shown

Expected Results:
13 pages


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 93477d1a963e38e3319013e43835a8ffef200972
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-06-02_10:16:52
Locale: it-IT (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Dieter Praas 2019-06-02 14:52:53 UTC
*** Bug 125639 has been marked as a duplicate of this bug. ***
Comment 2 Dieter Praas 2019-06-02 16:12:27 UTC
I confirm it with

Version: 6.3.0.0.beta1 (x64)
Build-ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: en-US (de_DE); UI-Sprache: de-DE
Calc: threaded

My results

1. Open attachment 147138 [details] => 15 pages (39653 characters)
2. CTRL+A + CTRL+C
3. CTRL+N
4. CTRL+SHIFT+C (Enable tracking changes) (for the new document)
5. CTRL+V => 13 pages
6. Accept all changes => 3 pages (39653 characters); last table is continuing besides page borders
7. Save and reload => 13 pages (39653 characters)

So I would say: Table not proper displayed after accepting all changes => pages disappear; I changed bug summary and hope you agree
Comment 3 Xisco Faulí 2019-06-11 11:16:12 UTC
i can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: ec905d131374f0860bac77c52873eed984b1966f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 4 Telesto 2019-06-11 12:09:14 UTC
No repro either
Version: 6.4.0.0.alpha0+ (x86)
Build ID: ac14e5613597e7361ce6995dacb1bb5bd55b6b00
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-06-06_05:09:49
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded