Download it now!
Bug 125666 - Deleting a (large) sheet very slow
Summary: Deleting a (large) sheet very slow
Status: RESOLVED DUPLICATE of bug 113112
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2019-06-03 17:54 UTC by Telesto
Modified: 2019-06-26 15:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-06-03 17:54:55 UTC
Description:
Deleting a (large) sheet very slow

Steps to Reproduce:
1. Open attachment 150858 [details] with and x32 and X64 build
2. Select columns ABC & Copy
3. Add a new sheet & paste (repeat 3 times)
4. Delete the first sheet

Actual Results:
Quite some time/processing power needed

Expected Results:
Rather fast


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 93477d1a963e38e3319013e43835a8ffef200972
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-06-02_10:16:52
Locale: it-IT (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Durgapriyanka 2019-06-03 21:30:44 UTC
Thank you for reporting the bug.
I can confirm the bug in 

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

and 
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 MM 2019-06-21 22:37:22 UTC
You don't even need to copy/paste anything.
Just open attachment 150858 [details].
Make a new sheet. Now delete the newly created sheet and wait a long time.
Comment 3 Xisco Faulí 2019-06-26 15:17:23 UTC
Fixed in master by the same commit fixing bug 113112

*** This bug has been marked as a duplicate of bug 113112 ***