Bug Hunting Session
Bug 125693 - MacOS: System dialogs are not in english
Summary: MacOS: System dialogs are not in english
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.beta1+
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest critical
Assignee: Stephan Bergmann
URL:
Whiteboard: target:6.4.0 target:6.3.0.2
Keywords:
: 125796 126288 126343 126473 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-06-04 23:00 UTC by Al Maloney
Modified: 2019-07-19 14:04 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Al Maloney 2019-06-04 23:00:29 UTC
On a Mac using macOS 10.12 go to /Applications/LibreOfficeDev.
Invoke «Show Package Contents»
Go to «Contents/Resources»
This directory is missing «en.lproj»

I copied this directory from LODev 6.2.5 and inserted it into LODev 6.3.0 beta1
This appears to have solved the problem.

Is this the same as Bug# 109090?
Comment 1 Xisco Faulí 2019-07-11 14:34:05 UTC
Confirmed in IRC by 2 people, One Australian with German menus and another user with Greek menus
Comment 2 Xisco Faulí 2019-07-11 14:37:19 UTC
According to cloph, this might have started after  http://cgit.freedesktop.org/libreoffice/core/commit/?id=8e3f4aeb401cb478374928d78bcbfc737bfd4d97

Adding Cc: to Stephan Bergmann
Comment 3 trainman75 2019-07-11 15:53:39 UTC
*** Bug 126343 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2019-07-11 15:55:18 UTC
*** Bug 126288 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2019-07-11 15:56:24 UTC
*** Bug 125796 has been marked as a duplicate of this bug. ***
Comment 6 Stephan Bergmann 2019-07-16 11:45:11 UTC
(In reply to Al Maloney from comment #0)
> On a Mac using macOS 10.12 go to /Applications/LibreOfficeDev.
> Invoke «Show Package Contents»
> Go to «Contents/Resources»
> This directory is missing «en.lproj»
> 
> I copied this directory from LODev 6.2.5 and inserted it into LODev 6.3.0
> beta1
> This appears to have solved the problem.

Just to make sure:  Am I right that (1) LibreOfficeDev.app/Contents/Resources/en.lproj is an empty directory in your 6.2.5 installation, and that (2) creating (copying) such an empty directory as LibreOfficeDev.app/Contents/Resources/en.lproj in your 6.3.0 solved the problem for you?
Comment 7 Stephan Bergmann 2019-07-16 11:57:59 UTC
xisco, when you changed the subject from "Print dialogue lacks english" to "MacOS: System menus are not in english", you wanted to write "System dialogs", not "System menus", right?
Comment 8 trainman75 2019-07-16 13:16:32 UTC
Yes, the presence of the correct but empty directory seems to make it happy, system dialogs are all in English.
Comment 9 Stephan Bergmann 2019-07-16 13:32:11 UTC
(In reply to trainman75 from comment #8)
> Yes, the presence of the correct but empty directory seems to make it happy,
> system dialogs are all in English.

OK, I can now reproduce that too when I set Slovenian as primary language (before English as second choice and then, as it happens to be for me, German as third choice):  In LO 6.3, Writer's "File - Open..." and "File - Print..." dialogs contain German controls, which change to English when adding an empty LibreOffice.app/Contents/Resources/en.lproj directory.
Comment 10 Martin Srebotnjak 2019-07-16 14:16:38 UTC
Could this be bibisected, I mean, there is probably some code removed or changed since 6.2 that just doesn't create that empty dir (or maybe there is a change in which a new/updated compiler version on macOS behaves)?
Comment 11 Stephan Bergmann 2019-07-16 14:19:48 UTC
(In reply to Martin Srebotnjak from comment #10)
> Could this be bibisected, I mean, there is probably some code removed or
> changed since 6.2 that just doesn't create that empty dir (or maybe there is
> a change in which a new/updated compiler version on macOS behaves)?

I already have a fix up at <https://gerrit.libreoffice.org/#/c/75728/> "tdf#125693: On macOS, create empty LibreOffice.app/Contents/Resources/en.lproj", stay tuned.
Comment 12 Commit Notification 2019-07-17 06:11:09 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/47a774fbef8c224e4853de3fdd0230b9442bb716%5E%21

tdf#125693: On macOS, create empty LibreOffice.app/Contents/Resources/en.lproj

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Martin Srebotnjak 2019-07-17 08:10:49 UTC
Hopefully also for 6.3.0?
Comment 14 Xisco Faulí 2019-07-17 08:12:20 UTC
(In reply to Martin Srebotnjak from comment #13)
> Hopefully also for 6.3.0?

See https://gerrit.libreoffice.org/#/c/75745/
Comment 15 Commit Notification 2019-07-17 08:34:17 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/069f218729fd4853e6c608abf5abd43a1224cdf8%5E%21

tdf#125693: On macOS, create empty LibreOffice.app/Contents/Resources/en.lproj

It will be available in 6.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Buovjaga 2019-07-19 14:04:30 UTC
*** Bug 126473 has been marked as a duplicate of this bug. ***