Bug 125711 - Large number of Comments (permanently) deleted, with record track changes enabled
Summary: Large number of Comments (permanently) deleted, with record track changes ena...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss
Depends on:
Blocks: Track-Changes Writer-Comments
  Show dependency treegraph
 
Reported: 2019-06-05 13:36 UTC by Telesto
Modified: 2021-06-26 16:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Minimized example file (27.76 KB, application/vnd.oasis.opendocument.text)
2021-06-26 14:05 UTC, NISZ LibreOffice Team
Details
The minimized example file in Writer (221.26 KB, image/png)
2021-06-26 14:07 UTC, NISZ LibreOffice Team
Details
The minimized example file after Delete All Comments (220.18 KB, image/png)
2021-06-26 14:12 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-06-05 13:36:32 UTC
Description:
Comments (permanently) deleted, with record changes enabled

Steps to Reproduce:
1. Open attachment 151939 [details]
2. Scroll down notice the comments on every page 
3. Check if record track changes is enabled (should be)
4. Select a the drop down button at a comment -> Delete a comments (wait)
5. Scroll down -> Scrolling is faster.. Yay.. Wait a minute.. there are lot less comments around

Actual Results:
Not all comments aren't tracked with record track changes enabled

Expected Results:
It probably should, or did I miss something?


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 93477d1a963e38e3319013e43835a8ffef200972
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-06-02_10:16:52
Locale: it-IT (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Timur 2019-06-05 14:23:04 UTC Comment hidden (obsolete)
Comment 2 Telesto 2019-06-05 14:58:28 UTC Comment hidden (obsolete)
Comment 3 Telesto 2019-06-05 14:59:13 UTC
Sorry, yes, Delete All Comments

1. Open attachment 151939 [details]
2. Observe that there are comments on every page (by scrolling down) 
3. Check if record track changes is enabled (should be)
4. Select a the drop down button on a comments -> Delete all comments (wait)
5. Scroll down to the bottom -> Notice comments are missing [with the positive side effect that scrolling is rather smooth]
Comment 4 Dieter 2019-06-05 16:51:54 UTC
I confirm it with

Version: 6.3.0.0.beta1 (x64)
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded

number of comments in original document: 1465
number of comments affected by track changes after delete all: 370
Comment 5 Telesto 2019-06-05 17:24:32 UTC
No repro with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

@Dieter
Where can I see the number of comments
Comment 6 Dieter 2019-06-05 17:45:32 UTC
(In reply to Telesto from comment #5)
> Where can I see the number of comments

Navigator => Tooltip if you click on "comments"
Comment 7 Timur 2019-06-06 07:14:04 UTC
Repro in LO 5.0. Also in Linux. 
When all comments are deleted, number shown in Navigator tooltip is first 5 then 370. Would be better if comment text was numbered.
Comment 8 Timur 2019-06-06 07:22:12 UTC
Doesn't seem like a real regression, rather incomplete fix. LO 4.4 first shows just 5 comments and later 1170 (and crashes). Could be related to comments handling (Bug 61558).
Comment 9 Timur 2020-05-14 13:24:41 UTC
Reproduced also with 4.3.0. I remove regression.
Comment 10 NISZ LibreOffice Team 2021-06-26 14:05:12 UTC
Created attachment 173224 [details]
Minimized example file

So what goes on with the original file: it contains about a page of lorem ipsum with 5 comments attached. This was copied and pasted over and over again, then change tracking was turned on and it was again pasted over and over again.

Consequently we have lots of pages with CT-added text and CT-added comments attached to it after page 78.

To reproduce the bug you need a fresh install and English UI so your user name is Unknown Author - does not happen with another user name. 
Choosing "Delete All Comments" now removes the CT-added comments as if they were added in the same review run: without crossing out.
This is similar to  being able to delete parts of the CT-added lorem ipsum text without being change tracked as deletion: because it is your own addition.

This simplified example shows this on 2 pages.
Comment 11 NISZ LibreOffice Team 2021-06-26 14:07:21 UTC
Created attachment 173225 [details]
The minimized example file in Writer
Comment 12 NISZ LibreOffice Team 2021-06-26 14:12:00 UTC
Created attachment 173226 [details]
The minimized example file after Delete All Comments

Comments from page 2 are gone, and on page 1 are crossed out, but this is not a bug, this is how it works.

Similarly with text: press Ctrl+A and press Delete: text on page 1 is crossed out as deletion and text on page 2 disappears since it's your own thing.

This happens only if you are Unknown Author. Fill the Options - User Data - First/last name fields and all deletions are tracked as new deletions.
Comment 13 NISZ LibreOffice Team 2021-06-26 14:14:02 UTC
Closing with NAB.

Side note: while testing the document I found that in 7.2 the original example attachment 151939 [details] (but not my simplified one) started to cause an endless loop on opening. 
Will report that separately.