Bug 125773 - A problem in libreoffice with persian language with inline formulas
Summary: A problem in libreoffice with persian language with inline formulas
Status: RESOLVED DUPLICATE of bug 115967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: RTL-CTL PDF-Export RTL-Arabic
  Show dependency treegraph
 
Reported: 2019-06-07 09:55 UTC by ni
Modified: 2019-09-26 11:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
this is the odt format. reproduce the problem using the file> export as> export as pdf (13.72 KB, application/vnd.oasis.opendocument.text)
2019-06-07 09:55 UTC, ni
Details
PDF export output LO 6.2.3.2 on Linux (20.34 KB, application/pdf)
2019-06-07 13:02 UTC, Eyal Rozenberg
Details
Document whose PDF export exhibits the bug (23.60 KB, application/vnd.oasis.opendocument.text)
2019-06-07 13:06 UTC, Eyal Rozenberg
Details
PDF export output of bug-152773 using LO 6.2.3.2 on Linux (21.93 KB, application/pdf)
2019-06-07 13:07 UTC, Eyal Rozenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ni 2019-06-07 09:55:20 UTC
Created attachment 152014 [details]
this is the odt format. reproduce the problem using the file> export as> export as pdf

Hello, I think there is a bug in libreoffice with persian language. I'm trying to write a technical text in libreoffice in farsi(persian) language. whenever i try to have inline formulas, like lambda/4 or L_r it is shown very poorly in final pdf. (it is not shown correctly). I don't use any extensions but the default formula editor of libreoffice and I export it as pdf by libreoffice default. could any developer please see this? I don't have this problem in open office but it exists in libreoffice. I don't have this problem with english language either. it just happens when I try to type persian. the problem doesnt exist in the odt format. just when I try to convert it to pdf. (which is important btw)
as I said the .odt format doesn't have problem. the PDF format is corrupt. to reproduce do this: File > Export as > Export as PDF.
Comment 1 Eyal Rozenberg 2019-06-07 13:02:10 UTC
Created attachment 152026 [details]
PDF export output LO 6.2.3.2 on Linux

Confirmed with:

Version: 6.2.3.2
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: he-IL (en_IL); UI-Language: en-US
Calc: threaded

It seems like the 'L' is horizontally shifted to the left of where it's supposed to appear, beyond some kind of rectangle boundary so that its left part is not rendered.
Comment 2 Eyal Rozenberg 2019-06-07 13:06:48 UTC
Created attachment 152027 [details]
Document whose PDF export exhibits the bug

This occurs both with Hebrew and with Farsi, and both when the paragraph is LTR and RTL (although the "run" containing the inline equation is RTL where the bug manifests).
Comment 3 Eyal Rozenberg 2019-06-07 13:07:42 UTC
Created attachment 152028 [details]
PDF export output of bug-152773 using LO 6.2.3.2 on Linux

This is the output we get.
Comment 4 Eyal Rozenberg 2019-07-21 22:24:22 UTC
Seeing this on AMD64, while original author sees this on IA32. Too bad the platform drop-down isn't multiple-choice...
Comment 5 ni 2019-09-19 16:32:41 UTC
This Bug is not even touched after I reported it in the new version of LO, Please Fix this.
Comment 6 Xisco Faulí 2019-09-26 11:06:32 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=302af8c2da58719844d22483b65a9fe5b3674684, which is the same as in bug

*** This bug has been marked as a duplicate of bug 115967 ***