Bug 125810 - Problem with toolbar customization with the Vertical Text box control
Summary: Problem with toolbar customization with the Vertical Text box control
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Customize-Dialog-Toolbars
  Show dependency treegraph
 
Reported: 2019-06-09 09:43 UTC by M Henri Day
Modified: 2019-06-10 07:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer toolbar (362.23 KB, image/png)
2019-06-09 09:43 UTC, M Henri Day
Details
Writer toolbar on Windows 10 (52.35 KB, image/png)
2019-06-09 16:20 UTC, M Henri Day
Details
Example of previous use of Vertical Text function in LO Writer (74.56 KB, image/png)
2019-06-09 17:07 UTC, M Henri Day
Details
Example of previous use of Vertical Text function in LO Writer (74.56 KB, image/png)
2019-06-09 17:12 UTC, M Henri Day
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M Henri Day 2019-06-09 09:43:54 UTC
Created attachment 152060 [details]
Writer toolbar

Unable to add Vertical text icon to the Writer toolbar or to implement the function when running 64-bit Linux Mint 19.1. No such difficulties when running Windows 10 (v 1903). I've now tested LO 6.3.0.0 beta and encounter the same difficulty.. 

Henri
Comment 1 M Henri Day 2019-06-09 09:50:45 UTC
When running 64-bit Linux Mint 19.1, I am unable to add the Vertical text icon to the Writer Toolbar or to implement the function. I don't encounter this difficulty when running 64.bit Windows 10 (v 1903). I've now installed 6.3.0.0 beta on my Linux machine, and experience precisely the same problem....

Henri
Comment 2 Luuk 2019-06-09 13:22:12 UTC
Same happens here on windows 6.2.4.2
Comment 3 Luuk 2019-06-09 13:29:02 UTC
Wait, you do say it works for you on Windows (v 1903), I also have v1903 and it 'does not work', I a unable to add 'Vertical Text' to the toolbar.
Comment 4 V Stuart Foote 2019-06-09 14:15:57 UTC
Not just in the Customize dialog.

On Windows 10 with TDF builds.

The Vertical Text button control is already present on the Standard toolbar--but it can not be set visible. Nor does it show when added to other toolbars as above.

Found on current master / 6.4.0alpha0 and 6.2.4.2; verified it was working with a 5.3.7 build.

@Maxim, you might be interested here.
Comment 5 Dave Barton 2019-06-09 14:20:49 UTC
I can confirm this issue.

The Vertical Text option appears in the Visible Buttons list, but cannot be made active on the toolbar, neither can it be added from the Customize Toolbar option in LO 6.2.4.2 under Linux, Windows 8.1 & 10(1903).

The issue does not exist in LO 6.2.4.2 under Windows 7.

I noticed the issue existed in a LO 6.3 alpha install from last week. I will grab a more recent copy tomorrow and report test results.

Dave
Comment 6 M Henri Day 2019-06-09 16:20:58 UTC
Created attachment 152064 [details]
Writer toolbar on Windows 10
Comment 7 M Henri Day 2019-06-09 16:25:26 UTC
While the Vertical Text icon can, as I noted above, indeed by added to the LO 6.2.4.2 Writer toolbar on Windows 10 (v 1903), as others have noted clicking it does not implement the function as the text remains horizontally aligned. Cf my second attachment above....

Henri
Comment 8 V Stuart Foote 2019-06-09 16:26:46 UTC
Crud, knew I'd seen this before. Dependent of profile settings for language support. A few toolbar buttons like this, RTL and LTR for example.

Button will show if support for CJK language is enabled from:

Tools -> Options -> Language Settings -> Languages: Default languages for documents.

Check the Asian box and select what language would be applied.

Dupe of bug 100616, or earlier bug 49680 wrapped up in work on bug 33356

But, kind o seems like this Text box feature should not necessarily be linked to enabling CJK or CTL paragraph handling--hmmm enhancement?
Comment 9 V Stuart Foote 2019-06-09 16:34:32 UTC
(In reply to M Henri Day from comment #7)
> While the Vertical Text icon can, as I noted above, indeed by added to the
> LO 6.2.4.2 Writer toolbar on Windows 10 (v 1903), as others have noted
> clicking it does not implement the function as the text remains horizontally
> aligned. Cf my second attachment above....
> 
> Henri

The Vertical Text box button action will create a new Text box holding text in a vertical orientation. And with CJK fonts that support it, the glyphs will rotate to a vertical orientation running up or down the page depending on locale.

The control does not convert existing paragraph content. It is not a direct formatting tool. Like the Horizontal draw Text box, you'd have to copy text and paste it into the text box.
Comment 10 M Henri Day 2019-06-09 17:07:14 UTC
Created attachment 152065 [details]
Example of previous use of Vertical Text function in LO Writer
Comment 11 M Henri Day 2019-06-09 17:12:27 UTC
Created attachment 152067 [details]
Example of previous use of Vertical Text function in LO Writer

I've now checked the situation on another machine running 64-bit Windows 10 v 1903, and find that there, just as in Linux Mint 19.1, the icon cannot be added to the Writer toolbar.

«The control does not convert existing paragraph content. It is not a direct formatting tool. Like the Horizontal draw Text box, you'd have to copy text and paste it into the text box.» Thank you, Stuart ; I am well aware as to how the tool is designed to be used, and which, indeed, worked as designed in previous versions of LO (I suspect the problem dates at least back to 6.2.3.2), cf the example New Years greetings which I sent to some Japanese friends and relatives  which I append hereto. I submit that this particular case is not an example of PEBCAK, but rather a real regression in LibreOffice which has not been resolved....

Henri
Comment 12 V Stuart Foote 2019-06-09 19:52:51 UTC
(In reply to M Henri Day from comment #11)
> 
> I've now checked the situation on another machine running 64-bit Windows 10
> v 1903, and find that there, just as in Linux Mint 19.1, the icon cannot be
> added to the Writer toolbar.

The icon is there on the Standard toolbar adjacent to the Draw Text box for Horizontal, it is just suppressed when no Asian language selection is made.

So, have you clear user profile--and then explicitly enabled a CJK Asian language entry from Tools -> Options -> Language Settings -> Languages? 

Defaults for a Western locale install will not enable the selection, it must be specifically set for a new profile.
Comment 13 M Henri Day 2019-06-10 07:53:16 UTC
Thanks, Stuart ; your suggestion did the trick. After upgrading to LO 6.2.4.2 (and, I suspect, even earlier in connexion with the upgrade to LO 6.2.3.2), the setting for Asian languages seems to have automatically been unchecked. Selecting one of the alternatives for these languages made the Vertical Text icon visible and allowed me to enter text vertically. I guess it was a case of PEBCAK after all ; thanks again for helping me - and others - to clear it up !...

Henri