Bug Hunting Session
Bug 125842 - Language of caption labels is not the same as the document language
Summary: Language of caption labels is not the same as the document language
Status: RESOLVED DUPLICATE of bug 104089
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Caption
  Show dependency treegraph
 
Reported: 2019-06-10 21:40 UTC by muso
Modified: 2019-06-12 17:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description muso 2019-06-10 21:40:37 UTC
Description:
I use LO with German menus but I need to write with it German and English texts. Therefore I specify the English texts as such and then spell checking and other language-related things work correct. But the image caption labels are always wrong.

Steps to Reproduce:
- run LO with English menus
- open or create a German document
- insert there an image and subsequently a caption.

result: the caption label is the English "Figure" but since this is a German document the caption must be "Abbildung".

I cannot find another way to fix this than to restart LO with the menu language equal to the document language I want to use. But this is no real workaround because I often have to work on English and German documents the same time and don't want to restart LO all the time.

Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 m.a.riosv 2019-06-10 22:18:20 UTC
I don't think a bug, but a request for enhancement.

Maybe easy if it was in relation with local-settings language.
Comment 2 Dieter Praas 2019-06-11 06:08:36 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: b170256fb6ebaf774b02b89835b19d9f3a1afb89
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-07_03:30:35
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

I would expect, that auto caption follows the default language setting for the document (Tools => Options => Language Settings => Languages)

Muso, you get a German caption if you change entries in (Tools => Options => LibreOffice Writer => AutoCaption). 

I add design team for further input.
Comment 3 muso 2019-06-11 22:53:09 UTC
> you get a German caption if you change entries in (Tools => Options =>
> LibreOffice Writer => AutoCaption). 

This doesn't solve the problem. I don't want to set a fixed language for the caption labels but the language of the document should be used - independent of the LO menu language.

Note, I don't use AutoCaption because about half of the images I insert to texts are small ones without a caption.
Comment 4 Dieter Praas 2019-06-12 06:26:08 UTC
(In reply to muso from comment #3)
> > you get a German caption if you change entries in (Tools => Options =>
> > LibreOffice Writer => AutoCaption). 
> 
> This doesn't solve the problem. I don't want to set a fixed language for the
> caption labels but the language of the document should be used - independent
> of the LO menu language.


Muso, thank you for clarification. As a workaround you can easily type "Abbildung" instead of "Figures" in the Insert Caption dialog.

Perhaps your bug is a duplicate of bug 104089.
Comment 5 muso 2019-06-12 08:39:10 UTC
> Muso, thank you for clarification. As a workaround you can easily type
> "Abbildung" instead of "Figures" in the Insert Caption dialog.

Many thanks Dieter. This workaround works when I add the captions manually but is of course annoying to type in the label again and again.
When I use Auto Caption this workaround does not work then I will have to change the caption afterwards which costs me even more some clicks before I can do this.

I wrote a lot of documents recently and this bug annoys me the most.

> Perhaps your bug is a duplicate of bug 104089.

Indeed. However maybe this one should stay open for the guys working on auto caption. Please decide.
Comment 6 Dieter Praas 2019-06-12 13:55:24 UTC

*** This bug has been marked as a duplicate of bug 104089 ***
Comment 7 Heiko Tietze 2019-06-12 14:05:25 UTC
You can also just enter the string you want in the caption field. Just overwrite Figure with Abbildung and it is available the next time.
Comment 8 muso 2019-06-12 15:29:01 UTC
(In reply to Heiko Tietze from comment #7)
> You can also just enter the string you want in the caption field. Just
> overwrite Figure with Abbildung and it is available the next time.

As I wrote in comment 5 this doesn't solve the problem. I have to work on different texts in different languages the same time. Using again and again the right caption labels is as if there is no automatic label feature and it is error prone as well (because of typos) and consumes unnecessarily time.
Comment 9 Heiko Tietze 2019-06-12 17:40:57 UTC
Okay, last idea for a workaround is to use templates.