Bug Hunting Session
Bug 125873 - UI: Selected border color preview isn't shown in the combobox (always black if OpenGL is disabled)
Summary: UI: Selected border color preview isn't shown in the combobox (always black i...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.0.1
Keywords: bibisected, bisected, regression
: 126091 126140 126141 (view as bug list)
Depends on:
Blocks: Page-Dialog
  Show dependency treegraph
 
Reported: 2019-06-12 08:23 UTC by Telesto
Modified: 2019-07-05 09:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-06-12 08:23:09 UTC
Description:
UI: Selected border color preview isn't shown in the combobox (always black)

Steps to Reproduce:
1. Open Writer
2. Format -> Page -> Border tab
3. Pick any color -> Say yellow -> Label will be yellow (and working fine), but shows a black box

Actual Results:
Black box

Expected Results:
Yellow box


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 95462a02a3aee1e3e7f9aa8fc50ba25fee3fa592
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-03_07:09:38
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Dieter Praas 2019-06-12 08:36:49 UTC
Can't confirm with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: b170256fb6ebaf774b02b89835b19d9f3a1afb89
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-07_03:30:35
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 2 Telesto 2019-06-12 09:02:56 UTC
(In reply to Dieter Praas from comment #1)
Would you mind to retest without OpenGL.. Appears to be fine with..
Comment 3 Dieter Praas 2019-06-12 09:08:55 UTC
Without OpenGL I can confirm it
Comment 4 Xisco Faulí 2019-06-13 16:50:40 UTC
not reproducible in

Version: 6.4.0.0.alpha0+
Build ID: ee4823e16e5fece068ee123b9c3e29834cd38763
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2019-06-13 17:33:09 UTC
Regression introduced by:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/319c57d2af5d26d3910db4b02dca145d8881af44

commit	319c57d2af5d26d3910db4b02dca145d8881af44	[log]
author	Noel Grandin <noel.grandin@collabora.co.uk>	Mon May 20 19:08:19 2019 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	Wed May 22 09:48:21 2019 +0200
tree	98a1c5529713fd9ff92af9e4fa535ee5a44d8447
parent	3847676cf616ccce40037444e8386dec059487bf [diff]

tdf#120837 File saving at least 5 times slower

Bisected with: win-6-3

Adding Cc: to Noel Grandin
Comment 6 Xisco Faulí 2019-06-26 11:05:43 UTC
*** Bug 126091 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2019-06-28 15:31:06 UTC
*** Bug 126140 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2019-06-29 15:07:47 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e73e7eacaeaa0b0eaccd3fdd25e10f0ed0d99779%5E%21

tdf#125873 Selected border color preview isn't shown

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2019-07-01 11:36:05 UTC
Verified in

Version: 6.4.0.0.alpha0+ (x64)
Build ID: f19156fdb5893ae8aeae93d65011d99d8c5e7735
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

@Noel, thanks for fixing this issue!!
Comment 10 Commit Notification 2019-07-01 11:39:42 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/379228d627845f669767b59967f1a13327b83224%5E%21

tdf#125873 Selected border color preview isn't shown

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2019-07-05 09:38:45 UTC
*** Bug 126141 has been marked as a duplicate of this bug. ***