Bug Hunting Session
Bug 125920 - FILEOPEN: DOC: file with EMF images takes double the time
Summary: FILEOPEN: DOC: file with EMF images takes double the time
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, perf, regression
Depends on:
Blocks: EMF-WMF DOC-Opening
  Show dependency treegraph
 
Reported: 2019-06-14 11:29 UTC by Xisco Faulí
Modified: 2019-09-24 11:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
perf flamegraph (135.52 KB, application/x-bzip)
2019-09-21 19:21 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-06-14 11:29:45 UTC
Steps to reproduce:
1. Download attachment 151400 [details] from bug 125281
2. Open it with 'time OOO_EXIT_POST_STARTUP=1 instdir/program/soffice <FILE PATH>'

in

Version: 6.4.0.0.alpha0+
Build ID: af37bb23f63b209af1193e20177c3aacbd777543
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and in

Version: 6.0.0.0.alpha1+
Build ID: 6eeac3539ea4cac32d126c5e24141f262eb5a4d9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

it takes

real	0m39,749s
user	0m33,265s
sys	0m6,208s

while in

Version: 5.4.0.0.alpha1+
Build ID: 9feb7f7039a3b59974cbf266922177e961a52dd1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

it takes

real	0m14,942s
user	0m10,629s
sys	0m3,279s
Comment 1 Julien Nabet 2019-09-21 19:21:05 UTC
Created attachment 154350 [details]
perf flamegraph

On pc Debian x86-64 with master sources updated today + enable-symbols, I retrieved a Flamegraph
Comment 2 Xisco Faulí 2019-09-24 11:28:19 UTC
it takes

real	0m7,601s
user	0m3,751s
sys	0m0,228s


in

Version: 6.4.0.0.alpha0+
Build ID: a283627036c9b1c56e4b765866b8fb8a26ec87ab
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and

real	0m8,461s
user	0m3,330s
sys	0m0,231s

in

Versió: 6.3.1.2
ID de la construcció: 1:6.3.1~rc2-0ubuntu0.18.04.1~lo1
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: es-ES (ca_ES.UTF-8); Llengua de la IU: ca-ES
Calc: threaded

So it seems the problem is gone