Download it now!
Bug 125947 - UI: "Spin Button" and "Scrollbar" are missing from default Form Controls toolbar
Summary: UI: "Spin Button" and "Scrollbar" are missing from default Form Controls toolbar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:6.4.0 target:6.3.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-16 05:03 UTC by stragu
Modified: 2019-06-19 11:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stragu 2019-06-16 05:03:56 UTC
Description:
For some reason, "Spin Button" and "Scrollbar" are not shown by default in the Form Controls toolbar in LO Calc 6.3.
They seem to be common controls (at least, more common than others), so I can't see why they would have been removed from the default toolbar between 6.2 and 6.3. I assume it's an error that happened when it was reorganised (i.e. there isn't a separate "More controls" section like there was in 6.2).

Steps to Reproduce:
1. In top menu: "View > Toolbars > Form Controls"

Actual Results:
"Spin Button" and "Scrollbar" items are missing (but can be added back if wanted)

Expected Results:
Those two common controls should be shown by default, there is not reason to hide those two over all the other controls.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 stragu 2019-06-16 05:04:57 UTC
Tested on:

Version: 6.3.0.0.alpha1
Build ID: 547edd20e527fb02900f6174973770d26306e2e7
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 m.a.riosv 2019-06-16 09:50:06 UTC
Repro
Version: 6.3.0.0.beta1 (x64)
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
Comment 3 stragu 2019-06-17 05:41:14 UTC
This commit (related to merging the two toolbars: https://bugs.documentfoundation.org/show_bug.cgi?id=112411) set the two buttons to `toolbar:visible="false"` for some reason: https://gerrit.libreoffice.org/plugins/gitiles/core/+/e89eba0e1fa56c64e0d572b4f32ce5951378c1d7%5E%21
Comment 4 Julien Nabet 2019-06-17 10:12:47 UTC
Heiko: one for you?
Comment 5 Heiko Tietze 2019-06-17 10:24:21 UTC
Assigning to Roman as he stated to take it in the other bug. I wonder if there was a reason to drop/hide controls. Please check the commit messages, haven't found anything in BZ.
Comment 6 Roman Kuznetsov 2019-06-17 17:50:50 UTC
(In reply to Heiko Tietze from comment #5)
> Assigning to Roman as he stated to take it in the other bug. I wonder if
> there was a reason to drop/hide controls. Please check the commit messages,
> haven't found anything in BZ.

No reason, some copy/paste and I forgot fix it=(
Comment 7 Commit Notification 2019-06-18 07:56:34 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/385128671716e70b9540a67e213d6495bf50662b%5E%21

tdf#125947 Two tools are missing from default Form Controls toolbar

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 stragu 2019-06-18 10:06:07 UTC
Thank you Roman and Heiko!

Any reason why this won't make it into 6.3? It looks like a minor fix on a new 6.3 feature, very unlikely to disrupt anything.
Comment 9 Julien Nabet 2019-06-18 13:02:07 UTC
(In reply to stragu from comment #8)
>...
> Any reason why this won't make it into 6.3? It looks like a minor fix on a
> new 6.3 feature, very unlikely to disrupt anything.

The patch is waiting for some review here:
https://gerrit.libreoffice.org/#/c/74267/
Comment 10 Commit Notification 2019-06-19 01:25:20 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/099d183410eb7b0dbede3db70966d54a41a971d7%5E%21

tdf#125947 Two tools are missing from default Form Controls toolbar

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 stragu 2019-06-19 11:44:30 UTC
Thank you! :)