Download it now!
Bug 125951 - Reversed RTL text in PDF when opened with Draw
Summary: Reversed RTL text in PDF when opened with Draw
Status: RESOLVED DUPLICATE of bug 104597
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-16 10:29 UTC by Zev Spitz
Modified: 2019-11-29 12:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF file with RTL text in it (831.29 KB, application/pdf)
2019-06-16 10:31 UTC, Zev Spitz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zev Spitz 2019-06-16 10:29:59 UTC
Description:
Keyword: FILEOPEN

When some PDF containing RTL text is opened, RTL text is rendered from left-to-right.

Steps to Reproduce:
1.Open a PDF with RTL text using Draw

Actual Results:
Text appears as LTR.

Expected Results:
RTL text should be in LTR.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_IL); UI-Language: en-GB
Calc: threaded
Comment 1 Zev Spitz 2019-06-16 10:31:25 UTC
Created attachment 152227 [details]
PDF file with RTL text in it
Comment 2 Zev Spitz 2019-06-16 10:38:20 UTC

*** This bug has been marked as a duplicate of bug 89471 ***
Comment 3 Xisco Faulí 2019-11-29 12:51:46 UTC

*** This bug has been marked as a duplicate of bug 104597 ***