Bug 125954 - Form wizard creates separate form controls inside a tablecontrol
Summary: Form wizard creates separate form controls inside a tablecontrol
Status: RESOLVED DUPLICATE of bug 125953
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Database-Forms
  Show dependency treegraph
 
Reported: 2019-06-16 14:07 UTC by Robert Großkopf
Modified: 2019-06-20 13:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots shows the created form of the wizard. Funny: Controls will work! (68.36 KB, image/png)
2019-06-16 14:07 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2019-06-16 14:07:09 UTC
Created attachment 152230 [details]
Screenshots shows the created form of the wizard. Funny: Controls will work!

Start to create a form by wizard with the attachment of
https://bugs.documentfoundation.org/show_bug.cgi?id=125953
Try to choose in Step 5 other possibilities than "Data Sheet".
Try to finish - wont work. This is bug 125953.
Now go back to Step 5 and choose "Data Sheet".
Finish the wizard.
I got a tablecontrol where the standalone-controls were positioned inside the tablecontrol.
You could see the result I got in the attached screenshot and in the form of the attachment of bug 125953.

All tested with LO 6.2.0.0.beta1 on OpenSUSE 15 64bit rpm Linux.
Comment 1 Robert Großkopf 2019-06-16 14:09:10 UTC
(In reply to Robert Großkopf from comment #0)
> 
> All tested with LO 6.2.0.0.beta1 on OpenSUSE 15 64bit rpm Linux.

Wrong version: 
Version: 6.3.0.0.beta1
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 6; OS: Linux 4.12; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Alex Thurgood 2019-06-18 07:20:54 UTC
Confirmed with

Version: 6.4.0.0.alpha0+
Build ID: eda0568ec550a10b962c2427edfe05ea3197f107
CPU threads: 4; OS: Mac OS X 10.14.5; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-06-20 13:29:24 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=0217031a98508731f15df9d361a6e5b584db5716

author	Tamas Bunth <tamas.bunth@collabora.co.uk>	2017-12-27 20:25:33 +0100
committer	Tamás Bunth <btomi96@gmail.com>	2017-12-28 16:19:37 +0100
commit	0217031a98508731f15df9d361a6e5b584db5716 (patch)
tree	688d255d306f8b8e06cff358fc9cbc988db1dabc
parent	5877a3733c55d51f86edeb17c227fd89363154e4 (diff)
tdf#104734 Firebird: Add LONGVARBINARY/Image type

Bisected with: bibisect-linux64-6.1

Adding Cc: to Tamas Bunth
Comment 4 Xisco Faulí 2019-06-20 13:34:54 UTC
I believe this issue wouldn't happen if bug 125953 were fixed... Only happening with Firebird, CLOB[BLOB] fields and if a different arrangement is used... don't think it's high priority bug
Comment 5 Xisco Faulí 2019-06-20 13:43:26 UTC
(In reply to Xisco Faulí from comment #4)
> I believe this issue wouldn't happen if bug 125953 were fixed... Only
> happening with Firebird, CLOB[BLOB] fields and if a different arrangement is
> used... don't think it's high priority bug

Yep, I believe it can be closed as dupe of bug 125953.

-> it works if Bild_Blob, Blob and Clob are not selected, thus we just need support for CLOB Variables after https://cgit.freedesktop.org/libreoffice/core/commit/?id=0217031a98508731f15df9d361a6e5b584db5716

*** This bug has been marked as a duplicate of bug 125953 ***