Bug 125974 - New bug: Searching in comments doesn't work
Summary: New bug: Searching in comments doesn't work
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-18 00:42 UTC by DarkTrick
Modified: 2019-09-05 12:13 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file for searching in comments (25.78 KB, application/vnd.oasis.opendocument.text)
2019-06-18 00:42 UTC, DarkTrick
Details
search buttons (36.28 KB, image/png)
2019-06-18 02:49 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DarkTrick 2019-06-18 00:42:05 UTC
Created attachment 152255 [details]
Example file for searching in comments

Reproduce:
1) open attached file (example.odt)
2) Press Ctrl+F for searching
3) Search for "Comment" 
3.b) Set search option from "Page" to "Comment" (Combo box to the right of the search field)

4) 
  Expected: 
    Finds comment inserted on page 3.
 
  Actual: 
    Does not find any match



Note: Title says "New bug". This is because, this bug was not there in version 
Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.5
Comment 1 raal 2019-06-18 02:39:23 UTC
Confirm with 6.4master
Comment 2 raal 2019-06-18 02:48:01 UTC
I was wrong. It works for me in Version: 6.4.0.0.alpha0+
Build ID: ee4823e16e5fece068ee123b9c3e29834cd38763
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

Seems to be fixed with dev version. Please could you test it with
dev version?  You can download it here:
http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 3 raal 2019-06-18 02:49:39 UTC
Created attachment 152260 [details]
search buttons

also be sure, you're using search buttons on the right
Comment 4 DarkTrick 2019-06-25 05:24:02 UTC
> Please could you test it with dev version?
I will try as soon as I have the resources.

> also be sure, you're using search buttons on the right

The buttons on the right do not search. They just focus every comment one by one, no matter of their content.
I also think, that, as long as comments are shown it should be possible to search then through the usual work flow: Ctrl+F, type term, "enter" for search.
Comment 5 QA Administrators 2019-06-26 02:48:25 UTC Comment hidden (obsolete)
Comment 6 Dieter 2019-06-27 16:49:48 UTC
You can search in comments with the toolbar, if you disable comments in Edit => Find & Replace. So I assume, that this option is enabled in your version 6.0.7.3.

Could you please check this => NEEDINFO
Comment 7 DarkTrick 2019-08-13 04:02:38 UTC
(Answer to Commment #6 from Dieter Praas)
>You can search in comments with the toolbar, if you disable comments in Edit => Find & Replace. So I assume, that this option is enabled in your version 6.0.7.3.

Opposite logic:
You can ENable comments within the "Find & Replace" dialog. After ENabling it there, you can search within comments.

The option for searching in comments should not be hidden inside the Find & Replace dialog. I suggest a UI change.
Should I create a new bug for that or can we go on in here?


===============================================
Reproduction log for searching in comments
@Version 6.4.0.0.alpha0+
===============================================

A Document contains a comment with content "comment".

--1--
1) Ctrl + F 
2) Type "comment"
3) Keep "Page" in the combo box to the right
4) Enter
❌result: does not find "comment".

--2--
1) Ctrl + F 
2) Type "comment"
3) Set combo box to the right to "Comment"
4) Enter
❌result: does not find "comment".

--3--
1) Ctrl + F 
2) Type "comment"
3) Set combo box to the right to "Comment"
4) Click the arrows next to the combo box to the right
❌result: writer steps to every comment, regardless of its content.

--4--
1) Menu -> Edit -> Find & Replace 
2) Type "comment"
3) click button "find next"
❌result: does not find "comment".

--5--
1) Menu -> Edit -> Find & Replace 
2) Type "comment"
3) Activate Checkbox "comments"
4) click button "find next"
✅result: finds "comment".

--6--
1) Menu -> Edit -> Find & Replace 
2) Activate Checkbox "comments"
3) close dialog
4) Type "comment"
5) Keep "Page" in the combo box to the right
6) Enter
✅result: finds "comment" as expected.



-----------------------------------------------------------

(Answer to Comment #3 from raal)
> also be sure, you're using search buttons on the right
As stated above, they are not search buttons.
However, regardless of their function, hitting the enter key should end up in the desired behaviour.
Comment 8 DarkTrick 2019-08-13 04:54:23 UTC
Related Information, that should be taken into consideration when fixing: 

If 
1) "search in comments" is activated within the "Find & Replace" dialog
2) Comments are not shown (Menu -> View -> Uncheck "Comments"

Then 
Comments are searched. For the user it looks like "the page is jumping around randomly".
Comment 9 Xisco Faulí 2019-08-19 15:09:51 UTC
Indeed, the down arrow from the right just moves the cursor to the next comment

Issue reproduced in

Version: 6.4.0.0.alpha0+
Build ID: cbe9601e5972ec1c466311e0b148a9fbe8cda4d1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e


LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

thus, not a regression. probably already reported.

@Jim, I thought you might be interested in this issue...
Comment 10 Xisco Faulí 2019-08-19 15:13:27 UTC
oh, wait a second. you have to select 'comment' in the search options ( bottom next to Match Case )
Closing as RESOLVED NOTABUG
Comment 11 DarkTrick 2019-08-20 01:38:29 UTC
(In reply to Xisco Faulí from comment #10)
> oh, wait a second. you have to select 'comment' in the search options (
> bottom next to Match Case )
> Closing as RESOLVED NOTABUG

Please see case --2-- from my Comment 7
I already tried that.
Comment 12 Xisco Faulí 2019-08-20 08:17:09 UTC
(In reply to BottleOnTheGround from comment #11)
> (In reply to Xisco Faulí from comment #10)
> > oh, wait a second. you have to select 'comment' in the search options (
> > bottom next to Match Case )
> > Closing as RESOLVED NOTABUG
> 
> Please see case --2-- from my Comment 7
> I already tried that.

I think you're mixing things up. On the left you have the search box, on the right, the navigate by menu, they have different purposes. Maybe they should be separated to make it clearer.
Adding UX Team
Comment 13 Dieter 2019-08-20 09:23:00 UTC
(In reply to Xisco Faulí from comment #12)
> Maybe they should
> be separated to make it clearer.
> Adding UX Team

I agree. Better to open a news bug report for that?
Comment 14 Dieter 2019-08-20 09:25:45 UTC
(In reply to BottleOnTheGround from comment #7) 
> The option for searching in comments should not be hidden inside the Find &
> Replace dialog. I suggest a UI change.
> Should I create a new bug for that or can we go on in here?

Yes, I recommend to open a new report like "Make comments searchable by default" and mark that as enhancement request.

Since comments are searchable (if you know the settings) I would close this bug as RESOLVED WORKSFORME.
Comment 15 Xisco Faulí 2019-08-20 10:16:58 UTC
(In reply to Dieter Praas from comment #14)
> (In reply to BottleOnTheGround from comment #7) 
> > The option for searching in comments should not be hidden inside the Find &
> > Replace dialog. I suggest a UI change.
> > Should I create a new bug for that or can we go on in here?
> 
> Yes, I recommend to open a new report like "Make comments searchable by
> default" and mark that as enhancement request.
> 
> Since comments are searchable (if you know the settings) I would close this
> bug as RESOLVED WORKSFORME.

+1.
Closing as RESOLVED NOTABUG