Bug Hunting Session
Bug 125976 - Enhance: Improve readability for many comments (difficult to distinguish)
Summary: Enhance: Improve readability for many comments (difficult to distinguish)
Status: RESOLVED DUPLICATE of bug 38295
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: All Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2019-06-18 01:18 UTC by BottleOnTheGround
Modified: 2019-08-08 08:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example for very hard to differentiate comments (26.07 KB, application/vnd.oasis.opendocument.text)
2019-06-18 01:18 UTC, BottleOnTheGround
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BottleOnTheGround 2019-06-18 01:18:03 UTC
Created attachment 152259 [details]
Example for very hard to differentiate comments

Reproduce:
1) Open Attached file 
  ( I don't know how to reproduce to make the comments blue, so the attachment is the easiest way. Here I copied-to-clipboard between a VM and a host. )

2) Comments, that are not shown in yellow (in my case it's blue comments) are very hard to distinguish from each other . Yellow comments receive a frame, when the cursor hovers over the respecting comments.


Suggestion:
 1) Regardless of the comment color, the behaviour regarding emphasizing focused comments should be the same
 2) Maybe a more obvious way of showing the focussed comment, when the text cursor is on the text element, that was commented
 3) Maybe "Ctrl + mouseclick on comment-triangle" could let the cursor and view jump inside the comment box
Comment 1 Dieter Praas 2019-07-03 18:25:17 UTC
In LO 6.2.5.2 first comment is blue, other comments are green. I don't know where to define comment background.

In 6.4.0.0. first comment is yellow, other comments are green and I can't see a difference, if cursor hovers over a comment.

See also bug 61242 Customise comments background color in Writer
Comment 2 Heiko Tietze 2019-08-08 08:41:04 UTC
Comments are colored by authors, so blue is your vm and green the host. The referenced place in the document is in fact not so easy to spot but take a look at the line, it changes from dashed to continuous. Regarding the readability I make this a duplicate of an older issue. Feel free to reopen if you disagree.

*** This bug has been marked as a duplicate of bug 38295 ***