Download it now!
Bug 125981 - The "Default" button for quotes in AutoCorrect options doesn't reset the display of replacement
Summary: The "Default" button for quotes in AutoCorrect options doesn't reset the disp...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:6.4.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2019-06-18 09:17 UTC by Ming Hua
Modified: 2020-08-30 06:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ming Hua 2019-06-18 09:17:38 UTC
Description:
In Tools -> AutoCorrect Options -> Localized Options tab, the user can change the replacement of ASCII single quotes (') and double quotes (").  Click the buttons with the respective symbols, and a character selection dialog will pop out, the user can then choose the character he/she want to replace the ASCII character with.  So far so good.

After playing with such settings, if the user doesn't want them and just want the default setting back for his/her locale, there are two helpful buttons labelled "Default" under them.  Clicking these buttons will indeed set the replacement back (one can check by clicking the buttons above again), however, the *display* of the replacement after the buttons with quotes are not reset to "Default" as before.  Instead, it seems to display the previous choice of the start quote for both buttons.

Steps to Reproduce:
1. Tools -> AutoCorrect Options -> Localized Options tab.
2. Click on the button with ' under Single Quotes -> Start quote.
3. Choose any character other than the default, say, Dagger (U+2020).
4. Now the display to the right of the buttons changes from "Default" to "† (U+2020)".
5. Click on the button labelled "Default" at the bottom.

Actual Results:
Both display to the right of the ' buttons show "† (U+2020)".

Expected Results:
Both display should be "Default".


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.2.4.2 (x64)
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded

A side note:  I also find the UI here a bit counter-intuitive.  If we are changing the replacement character, shouldn't the replacement be labelled on the button, instead of the character to be replaced (' and ")?
Comment 1 Durgapriyanka 2019-06-20 15:29:24 UTC
Thank you for reporting the bug. I can confirm the bug present in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

But, cannot reproduce in 

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

It works exactly as expected
Comment 2 Xisco Faulí 2019-06-28 14:01:48 UTC
Adding regression keyword based on comment 1
Comment 3 Buovjaga 2020-06-06 18:57:11 UTC
Bibisected with Linux 6.3 repo to https://git.libreoffice.org/core/+/1bfebbf2505fe0135c390bc011258c60f3abfd35%5E!/
weld OfaQuoteTabPage

Adding Cc: to Caolán McNamara
Comment 4 Commit Notification 2020-06-06 20:19:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/361e62aaa32318bc5778bcf82059a18913f64492

Resolves: tdf#125981 use original label, not current label

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2020-06-06 20:20:27 UTC
fixed in master, backports to 7-0 and 6-4 in gerrit
Comment 6 Commit Notification 2020-06-06 22:58:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/900ffff8b5718113e5b3ab7e9fbf35b999661c39

Resolves: tdf#125981 use original label, not current label

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-06-09 11:33:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/1afbe253c41e0157dfd4c024e427085413038d5e

Resolves: tdf#125981 use original label, not current label

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Ming Hua 2020-06-28 17:38:49 UTC
Verified in 7.0.0 Beta2 on Windows 10.  Thanks Caolán!
Comment 9 John Davis 2020-08-30 05:47:22 UTC Comment hidden (spam)
Comment 10 John Davis 2020-08-30 05:47:51 UTC Comment hidden (obsolete, spam)