Bug 125985 - Chinese Conversion crashes calc (gtk/gtk3)
Summary: Chinese Conversion crashes calc (gtk/gtk3)
Status: RESOLVED DUPLICATE of bug 125982
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: GTK3 GTK2
  Show dependency treegraph
 
Reported: 2019-06-18 10:56 UTC by artur
Modified: 2019-06-21 11:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description artur 2019-06-18 10:56:38 UTC
1. open a new calc document 
2. Tools->Languages->Chinese Conversion

tested on 
Version: 6.2.5.0.0+
Build ID: 6c3ceaf3e4d59c658d0f9e4e1b22204be25f74e2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.0.0.alpha0+
Build ID: 6b888ac476fe6ac2ee96c7086cb8c24249f08473
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

does not happen in writer
Comment 1 Xisco Faulí 2019-06-18 12:34:16 UTC
Regression introduced by:

author	Kohei Yoshida <kohei.yoshida@collabora.com>	2017-02-28 17:52:10 -0500
committer	Kohei Yoshida <libreoffice@kohei.us>	2017-03-01 00:07:25 +0000
commit	10077a06d8f6d08f276f99024528ee31a57390a9 (patch)
tree	ce5a669a90878ee685c071bc2502822ca74faaba
parent	4f762202f647976ffd80c23bacada8401d633001 (diff)
Revert my fix for tdf#71409, to hopefully fix tdf#104381.

Bisected with: bibisect-linux-64-5.4

@Caolán, I thought you might be interested in this issue...
Comment 2 Julien Nabet 2019-06-19 21:03:44 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this even if I open soffice only then Calc.
Comment 3 Xisco Faulí 2019-06-21 11:57:51 UTC
Fixed in

Version: 6.4.0.0.alpha0+
Build ID: 9712f5d2316fa469b92f2f8092925e2cd4e8dd5b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

*** This bug has been marked as a duplicate of bug 125982 ***