Download it now!
Bug 126067 - Bullets - Modifications performed with slide scope end up modifying the master slide and all slides
Summary: Bullets - Modifications performed with slide scope end up modifying the maste...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:6.4.0 target:6.3.0.2
Keywords:
: 126066 (view as bug list)
Depends on:
Blocks: Impress-Bullet-Numbering-Dialog
  Show dependency treegraph
 
Reported: 2019-06-24 09:56 UTC by bureautiquelibre
Modified: 2020-10-20 02:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document (12.18 KB, application/vnd.oasis.opendocument.presentation)
2019-06-24 09:56 UTC, bureautiquelibre
Details
Screencap / applying modifications to slide level (721.46 KB, image/gif)
2019-06-24 09:56 UTC, bureautiquelibre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bureautiquelibre 2019-06-24 09:56:03 UTC
Created attachment 152368 [details]
Test document

Steps to reproduce:

Open attached document.

Check master slide.

Perform bullet modification and choose scope: Slide.

Apply modifications

Check master slide again --> master slide changed.

Check other slides: bullets changed.

Expected result: master slide should remain the same as scope was "slide". Other slides thabn active slide should remain untouched.

See screencap for demo.
Comment 1 bureautiquelibre 2019-06-24 09:56:46 UTC
Created attachment 152369 [details]
Screencap / applying modifications to slide level
Comment 2 bureautiquelibre 2019-06-24 10:06:33 UTC
*** Bug 126066 has been marked as a duplicate of this bug. ***
Comment 3 Durgapriyanka 2019-06-24 16:06:33 UTC
Thank you for reporting the bug.

I can reproduce the bug in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

But, I cannot reproduce the bug in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Xisco Faulí 2019-06-26 09:02:00 UTC
This is related to the new bullet numbering dialog...

Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: fe855eda54faf6196ad9dea12d8dc090b6d6c1da
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Commit Notification 2019-07-16 06:46:25 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/40bb9ac690d979ef544d5aa759bd734a176912a0%5E%21

tdf#126067 Fix slide scope feature.

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-07-16 07:22:11 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/910c65fc640b3e422f3c660ba71844552fa426b3%5E%21

Follow up patch tdf#126067 Correct indentation.

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-07-16 07:23:50 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/ee2f74f480874620b35db95e2e310f16264a3ddc%5E%21

tdf#126067 Fix slide scope feature.

It will be available in 6.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-07-16 07:23:56 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/8d9ab38937ead9cefbbdc8fc3dfda6e1f82136cd%5E%21

Follow up patch tdf#126067 Correct indentation.

It will be available in 6.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.