Bug 126085 - Insert date: Ctrl+; is confused with Ctrl+Shift+; on many (mostly European) keyboard layouts (de/it/et and more)
Summary: Insert date: Ctrl+; is confused with Ctrl+Shift+; on many (mostly European) k...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Mihkel Tõnnov
URL:
Whiteboard: target:7.1.0 target:7.0.0.2
Keywords:
: 127726 130073 132531 139559 (view as bug list)
Depends on:
Blocks: Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2019-06-25 12:56 UTC by Oliver Grimm
Modified: 2021-09-10 12:46 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Grimm 2019-06-25 12:56:51 UTC
Description:
Using (Ctrl + ;) to paste the current date always uses DD.MM.YYYY HH.MM.SS here with a de.de locale. Even if the number type for this cell is set to DD.MM.YYYY only, it still uses the complete date string. Invoking the command by menu entry works fine. Therefore I guess, libreoffice simply confuses "insert date" with "insert time" when using the short keys.

Steps to Reproduce:
1. be sure to run a german locale
2. press (Ctrl + 1) and set the number type for the current cell to a short date string (DD.MM.YYYY)
3. press (Ctrl + ;) to paste the current date


Actual Results:
instead of the current date, the current time is pasted.

Expected Results:
the current date is posted.


Reproducible: Always


User Profile Reset: No



Additional Info:
With a german keyboard layout ";" is invoked by pressing "Shift + ,". Therefore using "Ctrl + ;" for "insert date" and "Ctrl + Shift + ;" for "insert time" cannot work together. The easiest fix would be to assign a different keyboard shortcut to any one of these two. 
Maybe this also a bug for other keyboard layouts in which "," and ";" share the same key.

Version: 6.1.5.2
Build-ID: 1:6.1.5-3
CPU-Threads: 2; BS: Linux 4.19; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.utf8); Calc: group threaded
Comment 1 Julien Nabet 2019-06-25 14:13:12 UTC
Xisco: kind of dup with tdf#125306 but for another language?
Badfully, I didn't understand a Yousuf's patch concerning this part. (see https://bugs.documentfoundation.org/show_bug.cgi?id=125306#c3)
Comment 2 m.a.riosv 2019-06-25 21:27:08 UTC
It's supposed it was resolved https://bugs.documentfoundation.org/show_bug.cgi?id=88027, but I think not the issue remains for me with Spanish.

The workaround it's define a shortcut without the shift key in the combination.
Comment 3 Oliver Grimm 2019-06-26 08:20:03 UTC
@Julien: yes, it's a duplicate of tdf#125306 for another language. But I guess we need to fix it for each keyboard layout separately, right? So I will leave this one open in order to make sure it gets fixed.

Please have a look at tdf#88027 for additional discussion.
Comment 4 Julien Nabet 2019-06-26 08:24:59 UTC
(In reply to Oliver Grimm from comment #3)
> @Julien: yes, it's a duplicate of tdf#125306 for another language. But I
> guess we need to fix it for each keyboard layout separately, right? So I
> will leave this one open in order to make sure it gets fixed.
Ok, no pb for me.
Comment 5 Xisco Faulí 2019-06-28 12:45:20 UTC
I guess this is inherit from OOo
Comment 6 Oliver Grimm 2019-12-10 13:13:56 UTC
still a bug in LO 6.3.3
Comment 7 Oliver Grimm 2019-12-22 22:17:36 UTC
still a bug in 6.3.4
Comment 8 Ming Hua 2020-04-29 20:20:45 UTC
*** Bug 132531 has been marked as a duplicate of this bug. ***
Comment 9 stragu 2020-05-11 12:06:49 UTC
Confirmed with:

Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Interestingly, I can't even use the "Ctrl + Shift + ;" to insert the time in:

Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.18.04.1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded

But the menu does not show the shortcut for inserting the time, so I assume 6.4 is missing that?
Comment 10 Mihkel Tõnnov 2020-05-15 12:41:32 UTC
Hopefully this will be solved (for German as well as a bunch of other layouts) once https://gerrit.libreoffice.org/c/core/+/94305 goes through.
Comment 11 Heiko Tietze 2020-07-03 09:01:49 UTC
*** Bug 127726 has been marked as a duplicate of this bug. ***
Comment 12 Heiko Tietze 2020-07-03 09:02:10 UTC
*** Bug 129547 has been marked as a duplicate of this bug. ***
Comment 13 Mihkel Tõnnov 2020-07-03 09:32:53 UTC
*** Bug 130073 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2020-07-03 12:15:50 UTC
Mihkel Tõnnov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1c7d792ae27d2a899244d30a9c3cd3c04b5755ae

tdf#126085: Enable Ctrl+Comma & Ctrl+Shift+Comma with European layouts

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-07-07 02:43:05 UTC
Mihkel Tõnnov committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/e4f697e510e0450375895d15256f27ee666e2968

tdf#126085: Enable Ctrl+Comma & Ctrl+Shift+Comma with European layouts

It will be available in 7.0.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Mihkel Tõnnov 2020-07-09 10:40:04 UTC
Reopening to track some follow-up actions:
1) It was pointed out on ML that most users in NL use the US International layout, so the change should be reverted for nl-NL.
2) Many smaller European languages to be added.
3) Many languages using a Cyrillic script as well.

Also changing BR summary slightly to reflect that the scope here has been wider than only German layout.
Comment 17 Heiko Tietze 2020-07-09 13:02:30 UTC
(In reply to Mihkel Tõnnov from comment #16)
> 2) Many smaller European languages to be added.

Consider to change the default and make English the exception.
Comment 18 Mihkel Tõnnov 2020-07-09 13:21:44 UTC
(In reply to Heiko Tietze from comment #17)
> (In reply to Mihkel Tõnnov from comment #16)
> > 2) Many smaller European languages to be added.
> 
> Consider to change the default and make English the exception.

That would make matters worse, I think :) I haven't specifically counted, but my impression from going through a ton of layouts is that worldwide, there are more layouts used that *have* the semicolon key (i.e. based on US layout) than ones that do not (e.g. most European & Cyrillic layouts).
Comment 19 Commit Notification 2020-07-15 14:51:02 UTC
Mihkel Tõnnov committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/cc4c992563f12a5155c363d640deda195f127686

tdf#126085: Restore Ctrl+; & Ctrl+Shift+; shortcuts for nl-NL

It will be available in 7.0.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-08-12 07:53:33 UTC
Mihkel Tõnnov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3c8b3451c94aa6134752d110df58e93e6412cf02

tdf#126085: Restore Ctrl+; & Ctrl+Shift+; shortcuts for nl-NL

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Ziyad 2021-01-31 19:26:48 UTC
(In reply to Mihkel Tõnnov from comment #10)
> Hopefully this will be solved (for German as well as a bunch of other
> layouts) once https://gerrit.libreoffice.org/c/core/+/94305 goes through.

This bug is also found in Arabic and Persian for (Ctrl+'), (Ctrl+;), (Ctrl+[), (Ctrl+]) and even (Ctrl+Shift+ any of those keys), should I open a separate bug?
Comment 22 Oliver Grimm 2021-08-26 22:45:53 UTC
I confirm this is fixed now for german keyboards (de-DE).
Can others please check for their languages?
Comment 23 m.a.riosv 2021-08-27 14:13:30 UTC
Works for me [CtrlShift+;] time, [Ctrl+,] date.
Version: 7.1.5.2 (x64) / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: es-ES Calc: threaded
But if I have the UI in English, I can't with a Spanish keyboard layout.

I think the only way having this works in any language/keyboard layout, it's to avoid those combinations with shifts not equal in all keyboard layouts, I guess mainly, no letter keys and numbers.
Comment 24 stragu 2021-09-10 02:35:12 UTC
*** Bug 139559 has been marked as a duplicate of this bug. ***
Comment 25 stragu 2021-09-10 04:55:36 UTC
(In reply to Oliver Grimm from comment #22)
> I confirm this is fixed now for german keyboards (de-DE).
> Can others please check for their languages?

Oliver, which version of LO and which locale/UI language are you using?
How are you able to use both the Date and Time shortcuts (Ctrl + ; vs Ctrl + Shift + ;), if they are the same on the DE keyboard?

I still have the issue with the latest build of 7.3 alpha0+:

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 3749d9af3745c0eaff7239e379578e4e2af89e9d
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-09-09_07:27:56
Calc: threaded
Comment 26 Oliver Grimm 2021-09-10 12:43:15 UTC
@Stragu: inserting the date is now bound to Ctrl+,
inserting the time is now bound to Ctrl+; (=Ctrl+Shift+,)

So it is working now, at least for my (German) keyboard.
Since I am the original reporter, I will close this bug again.
Please feel to open a new bug for other languages.
Comment 27 Oliver Grimm 2021-09-10 12:46:14 UTC
my version is 
Version: 7.1.5.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 16; OS: Linux 5.10; UI render: default; VCL: kf5
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Debian package version: 1:7.1.5-2
Calc: threaded

I am running an up-to-date Debian Linux (Testing) here.