Bug Hunting Session
Bug 126091 - Wrong colors on drop-down gradient's color widgets on Sidebar in Draw
Summary: Wrong colors on drop-down gradient's color widgets on Sidebar in Draw
Status: RESOLVED DUPLICATE of bug 125873
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.beta2+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-06-25 16:26 UTC by Roman Kuznetsov
Modified: 2019-06-26 11:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
wrong colors (10.69 KB, image/png)
2019-06-25 16:28 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-06-25 16:26:53 UTC
Description:
Wrong colors on drop-down gradient's color widgets on Sidebar in Draw

Steps to Reproduce:
1. Open Draw
2. Draw any shape
3. Open Sidebar->Properties->Area
4. Select Fill: Gradient
5. Look at colors on drop-down wigets (see attach)
6. When you change color then colors on widgets don't change

Actual Results:
wrong colors

Expected Results:
right colors


Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.3.0.0.beta2 (x64)
ID сборки: 6c6edded7133daf2d8d0b2ea7ae25b8109c5c064
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: threaded

don't repro in 6.2.4 -> regression
Comment 1 Roman Kuznetsov 2019-06-25 16:28:07 UTC
Created attachment 152400 [details]
wrong colors
Comment 2 Julien Nabet 2019-06-25 16:39:17 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this with gtk3 or gen rendering.
Perhaps Windows only.
Comment 3 Roman Kuznetsov 2019-06-25 18:17:08 UTC
don't repro with enabled OpenGL!
Comment 4 V Stuart Foote 2019-06-25 22:22:13 UTC
Confirmed on Windows 10 Ent 64-bit en-US with
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 4808ae1c73597726c89936f5b9cb3f11c9a4a7bf
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-25_01:14:33
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

With default rendering (CPU only or HA), the widget button color swatch is black. But with OpenGL enabled, the widget button gets correct color swatch. 

Color swatches are correct on same system with 6.2.4.2 build both default and OpenGL rendering.
Comment 5 Xisco Faulí 2019-06-26 11:05:43 UTC
Regression introduced by https://gerrit.libreoffice.org/plugins/gitiles/core/+/319c57d2af5d26d3910db4b02dca145d8881af44, which is the same as in bug 125873

*** This bug has been marked as a duplicate of bug 125873 ***