Download it now!
Bug 126092 - Hang undoing move/copy sheet action
Summary: Hang undoing move/copy sheet action
Status: RESOLVED DUPLICATE of bug 113112
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, perf, regression
Depends on:
Blocks:
 
Reported: 2019-06-25 16:28 UTC by Xisco Faulí
Modified: 2019-06-26 15:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-06-25 16:28:54 UTC
This issue was found while testing bug 125661

Steps to Reproduce:
1. Open attachment 150858 [details]
2. Sheet -> Move or copy sheet
3. Undo

-> LibreOffice hangs

Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: 52800731baf9fcb88e54d60de5585640c8f97f7b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-06-25 16:31:18 UTC
Reproduced back to

Version: 4.1.0.0.alpha1+
Build ID: a2c9d4f8bbde97f175bae4df771273a61251f40

but not in

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 2 Xisco Faulí 2019-06-25 16:54:56 UTC
Regression introduced in range https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=8d8f9dd80abf4e1eb08eee9763ea38f2b15f02b8..af86f7b26f2fafbb0fdfe24682b4700a51334d18

@Dennis, @Lubos, I thought you might be interested in this issue...
Comment 3 Xisco Faulí 2019-06-26 15:14:05 UTC
Fixed in master by the same commit fixing bug 113112

*** This bug has been marked as a duplicate of bug 113112 ***