Bug 126098 - PGP keys unavailable to non-super user macOS GPGTools
Summary: PGP keys unavailable to non-super user macOS GPGTools
Status: RESOLVED DUPLICATE of bug 115538
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-26 03:49 UTC by Nathan
Modified: 2019-06-26 07:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan 2019-06-26 03:49:38 UTC
Description:
PGP keys are UNavailable in Preferences>User Data>Cryptography when program executed as administrator from Applications folder/spotlight

PGP keys are available when LibreOffice is executed from terminal using the following command: 'sudo /Applications/LibreOffice.app/Contents/MacOS/soffice'

I have reached out to GPGTools to see if there is a permission issue - will update.

Steps to Reproduce:
1.Open LibreOffice via 'standard' method (Applications folder, Spotlight, etc)
2.Open Preferences
3.LibreOffice>User Data
4.Cryptography>OpenPGP signing key: 'No key' is the only option.

Actual Results:
No key only option listed in drop-down menu.

Expected Results:
PGP private signing keys should be listed in drop-down menu. 

Keys are available when LibreOffice executed as su.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.2.4.2
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU threads: 8; OS: Mac OS X 10.14.5; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Alex Thurgood 2019-06-26 07:30:23 UTC

*** This bug has been marked as a duplicate of bug 115538 ***