Bug 126116 - Displayed form of date changes to dd-mm-yyyy when date is changed in cell with format dd-mm-yy
Summary: Displayed form of date changes to dd-mm-yyyy when date is changed in cell wit...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.beta1+
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.6
Keywords: regression
: 126581 126783 127549 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-06-26 14:34 UTC by Cor Nouws
Modified: 2019-09-17 10:59 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2019-06-26 14:34:54 UTC
New spreadsheet
- type 13-6
- enter
  >  displayed is 13-06-19
- focus back on cell
- type 14-6
- enter
  >  displayed is 14-06-2019

in Version: 6.4.0.0.alpha0+
Build ID: f75c2b04785aa05cff3bcd52689feb7400a14e8e
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-06-15_11:49:26
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Cor Nouws 2019-06-26 14:36:16 UTC
oops, also wrong in Versie: 6.3.0.0.beta1
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU-threads: 4; Besturingssysteem: Linux 5.0; UI-render: standaard; VCL: gtk3; 
Locale: nl-NL (nl_NL.UTF-8); UI-taal: nl-NL
Calc: threaded
Comment 2 Eike Rathke 2019-06-26 16:48:04 UTC
2 digit years are bad anyway ;-)
Comment 3 Jacques Guilleron 2019-06-26 17:04:58 UTC
Hi Cor,

I reproduce with
LO  6.4.0.0.alpha0+ (x86) Build ID: 719f4a93e46a6b397356dbb605d2867639ca3942
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: nl-NL (fr_FR); UI-Language: en-US Calc: CL
But not with
LO   6.3.0.0.alpha0+ Build ID: f6a64f9bdce16cc18bb086b0de894fba7e1538c3
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: nl-NL (fr_FR); UI-Language: en-US Calc: CL

Jacques
Comment 4 Eike Rathke 2019-06-26 21:26:57 UTC
I assigned this already to myself..
Comment 5 Cor Nouws 2019-06-27 06:07:21 UTC
(In reply to Eike Rathke from comment #2)
> 2 digit years are bad anyway ;-)
Well, I started using computers only in 1986. And in another 50 years from now - I should be nearly 110 - it's still not 2086.. So what's the problem :D
Comment 6 Eike Rathke 2019-06-27 10:58:14 UTC
Removing bibisectRequest again a second time, I don't need it.
Comment 7 Commit Notification 2019-06-27 13:58:13 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e6a1bbe6690474e752416c81e1ca8c82b2843539%5E%21

Resolves: tdf#126116 keep original date format if detected type is identical

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Eike Rathke 2019-06-27 13:58:40 UTC
Pending https://gerrit.libreoffice.org/74806 for 6-3
Comment 9 Commit Notification 2019-06-27 15:11:26 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/f800f73d8d115e05134fd3cd25573e2d5acaddd3%5E%21

Resolves: tdf#126116 keep original date format if detected type is identical

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2019-06-28 12:29:14 UTC
Hi Eike,
Should your fix be backported to 6-2 branch as well ?
Comment 11 Eike Rathke 2019-06-28 16:47:15 UTC
The change causing that isn't in 6-2
Comment 12 Eike Rathke 2019-06-28 16:48:44 UTC
Or wait, it is.. so yes, I'll do.
Comment 13 Eike Rathke 2019-06-28 16:49:50 UTC
https://gerrit.libreoffice.org/74856
Comment 14 Eike Rathke 2019-06-28 16:53:07 UTC
And even https://gerrit.libreoffice.org/74857 for 6-2-5 if review time permits.
Comment 15 Xisco Faulí 2019-06-28 17:56:01 UTC
(In reply to Eike Rathke from comment #14)
> And even https://gerrit.libreoffice.org/74857 for 6-2-5 if review time
> permits.

Too late for that
Comment 16 Cor Nouws 2019-07-01 15:26:14 UTC
Works OK in Version: 6.4.0.0.alpha0+
Build ID: 7440ca952c51a756bdc49d436abff1af25fe745b
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-06-27_16:34:10
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded

thanks Eike!
Comment 17 Commit Notification 2019-07-17 19:32:39 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/bb329b0fbcc416b122885511f6120992bb369959%5E%21

Resolves: tdf#126116 keep original date format if detected type is identical

It will be available in 6.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Eike Rathke 2019-07-31 18:33:57 UTC
*** Bug 126581 has been marked as a duplicate of this bug. ***
Comment 19 Oliver Brinzing 2019-08-09 07:14:32 UTC
*** Bug 126783 has been marked as a duplicate of this bug. ***
Comment 20 Oliver Brinzing 2019-09-15 17:09:46 UTC
*** Bug 127549 has been marked as a duplicate of this bug. ***