Bug Hunting Session
Bug 126147 - Inserting graphics with type TIFF *.tif
Summary: Inserting graphics with type TIFF *.tif
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.2.6 target:6.3.0.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Images-TIFF
  Show dependency treegraph
 
Reported: 2019-06-28 11:06 UTC by Hans
Modified: 2019-07-18 08:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test case: image *.tif (4.54 MB, image/tiff)
2019-06-28 11:12 UTC, Hans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans 2019-06-28 11:06:18 UTC
Description:
Writer and Draw 6.1.0.3 (64) doesn't insert graphics type *.tif with german comment "Unbekanntes Bildformat" (unknown format). At inserting a 2-page scan/picture there is only the first page to see.

Steps to Reproduce:
1.open new document
2.insert - picture (from directory)
3.

Actual Results:
error message or partially loaded image

Expected Results:
embed and scale the picture


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Hans 2019-06-28 11:12:29 UTC
Created attachment 152454 [details]
test case: image *.tif
Comment 2 MM 2019-06-28 15:12:08 UTC
Confirmed on windows 7 x64 with Version: 6.2.5.2 (x64)
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 3; OS: Windows 6.1; UI render: default; VCL: win

Unconfirmed with LibreOffice 3.3.4 
OOO330m19 (Build:401)
tag libreoffice-3.3.4.1


Confirmed on mint 19.1 x64 with Version: 6.4.0.0.alpha0+
Build ID: f75c2b04785aa05cff3bcd52689feb7400a14e8e
CPU threads: 2; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-06-15_11:49:26
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Aron Budea 2019-07-06 05:23:01 UTC
Bibisected to the following commit using repo bibisect-win32-5.1. Adding Cc: to Caolán McNamara.

However, I'd say there's something wrong with the file, the size is 1700x2800, which corresponds to the byte size, however there's a header, which results in a 192-byte offset, and those 192 bytes are missing at the end. Windows shows a preview of the file, but XnView fails to open it.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=97a0e7558b24792827d77217fb2d8b1106056963
author		Caolán McNamara <caolanm@redhat.com>	2015-07-20 12:28:03 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2015-07-20 12:30:28 +0100

bail if offsets are past eof
Comment 4 Caolán McNamara 2019-07-17 15:10:52 UTC
yeah, it appears as truncated to us since that tightening up
Comment 5 Commit Notification 2019-07-18 07:39:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c21847117a587f1eac99653d05e6ed9278d43f79%5E%21

Resolves: tdf#126147 relax sanity check and allow truncated tiffs

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2019-07-18 07:42:52 UTC
backport to 6-3 and 6-2 in gerrit
Comment 7 Commit Notification 2019-07-18 08:44:42 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/38bf835b48efa2e32d917538cabc4fa2e1dec56d%5E%21

Resolves: tdf#126147 relax sanity check and allow truncated tiffs

It will be available in 6.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-07-18 08:44:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/d743130a98a168ba17dcb082cd3fb6efc335a86a%5E%21

Resolves: tdf#126147 relax sanity check and allow truncated tiffs

It will be available in 6.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.