Bug Hunting Session
Bug 126164 - EDITING Error at Paste: Instead to overwrite selected text by text from clipboard selected text iis copied to clipbpoard
Summary: EDITING Error at Paste: Instead to overwrite selected text by text from clipb...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.beta2+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, possibleRegression
Depends on:
Blocks:
 
Reported: 2019-06-29 19:21 UTC by Stefan_Lange_KA@T-Online.de
Modified: 2019-07-20 22:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test document to show the problem (9.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-06-29 19:21 UTC, Stefan_Lange_KA@T-Online.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan_Lange_KA@T-Online.de 2019-06-29 19:21:22 UTC
Created attachment 152469 [details]
Test document to show the problem

When any text is copied into the clipboard and should be pasted into any not empty cell or comment and the cell or comment content, that should be overwritten by clipoard content, is selected (marked) by mouse, the paste action results in copy the selected cell or comment content to the clipboard instead of overwrite the selected text by clipboard content.

In my tests I couldn't reproduce this behavior, when the cell or comment content to overwrite at paste is selected by keyboard.

Reproduce the problem:
- open the attached document "Test_Copy+Paste.ods"
- right click into cell C1 and choose "Edit Comment"
- select all comment text (or only a part) by mouse, then right click into the selected text and choose "Copy" (or copy the text by Ctrl+C)
- click anywhere that comment box closes
- check clipboard content: right click into any empty cell and choose "Paste": The text "Kommentar zu Zelle C1" (or the selected part) is pasted -> OK
- right click into cell C2 and choose "Edit Comment"
- select all comment text (or a part) by mouse, then right click into the selected text and choose "Paste" (or paste the text by Ctrl+V)
Result: 
- The comment text remains unchanged.
- Instead now the selected text from comment is copied to clipboard: Right click into any empty cell and choose "Paste" -> the selected text from comment to C2 (all or the part) is inserted.
The same probleme exists when not comment content is edited but cell content.
Comment 1 Durgapriyanka 2019-07-01 14:39:08 UTC
Thank you for reporting the bug. I couldn't reproduce the bug in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Stefan_Lange_KA@T-Online.de 2019-07-01 16:05:55 UTC
I have tested the bug with actual builds of LO 6.3 beta2 and LO 6.4 alpha0.
It is relatively new and it occurs since about one or two weeks - to young to reproduce it with the build from 2019-01-30.
It doesn't occur in LO 6.2, recently tested with 
Version: 6.2.5.2 (x64)
Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

I have checked when it was introduced. I think it was at the step from LO 6.3 beta1 to LO 6.3 beta2:
- I cannot reproduce the behavior with
Version: 6.3.0.0.beta1 (x64)
Build-ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
- The bug is present in
Version: 6.3.0.0.beta2 (x64)
Build-ID: 6c6edded7133daf2d8d0b2ea7ae25b8109c5c064
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Language: de-DE
Calc: threaded
Comment 3 Stefan_Lange_KA@T-Online.de 2019-07-05 21:51:09 UTC
I have also checked when the bug was introduced in LO 6.4 alpha0+:
- I cannot reproduce the behavior with
Version: 6.4.0.0.alpha0+ (x64)
Build ID: b59a691d2f6b0d1b94ec68fa01768325e4a34dc9
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-17_23:52:41
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
- The bug is present in
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 11a1bdc5fa0312111ddf9c1b7779a114b97e361c
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-19_00:00:04
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 4 Jacques Guilleron 2019-07-06 15:17:37 UTC
Hi Stefan,  Durgapriyanka,

I reproduce too with
LO  6.4.0.0.alpha0+ (x86) Build ID: 719f4a93e46a6b397356dbb605d2867639ca3942
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: fr-FR (fr_FR); UI-Language: en-US Calc: CL
and
LO 6.4.0.0.alpha0+ (x86) Build ID: 11a1bdc5fa0312111ddf9c1b7779a114b97e361c
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: fr-FR (fr_FR); UI-Language: en-US Calc: CL
But not with
LO  6.3.0.0.alpha1 Build ID: 547edd20e527fb02900f6174973770d26306e2e7
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; VCL: win; 
Locale : fr-FR (fr_FR); Langue IHM : fr-FR Calc: CL

Have a nice day,

Jacques
Comment 5 Stefan_Lange_KA@T-Online.de 2019-07-06 20:43:11 UTC
Corresponding to Comment 2 (When the bug was introduced?) I have changed earliest affected version from 6.3.0.0 alpha to 6.3.0.0 beta2.
Comment 6 Stefan_Lange_KA@T-Online.de 2019-07-20 22:51:18 UTC
It seems the bug was solved without anyone has explicitely corrected it: I cannot reproduce the described behavior neither with
 
Version: 6.3.0.2 (x64)
Build-ID: 728469fa359ba8c83d812146293a0b0aa53945ba
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

nor with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 140b070bb187e3d5e35a588a1d187e3a40e11547
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-07-20_12:36:59
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

Therefore I change the bug to RESOLVED with reason WORKSFORME. OK?