Bug Hunting Session
Bug 126196 - User customization of the styles displayed in Toolbar Paragraph styles combobox droplist
Summary: User customization of the styles displayed in Toolbar Paragraph styles combob...
Status: RESOLVED DUPLICATE of bug 101748
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-02 14:00 UTC by Massimo Medolla
Modified: 2019-07-12 12:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Massimo Medolla 2019-07-02 14:00:32 UTC
About paragraph style combobox in the toolbar. It would be very good to have styles ordered by more used styles or give to user the possibility to choice the styles to show. This can improve usability.
Comment 1 V Stuart Foote 2019-07-03 12:21:47 UTC
It would be nice to support customization and allow user to pick which styles appear in the toolbar drop lists, and I guess likewise a matching customized content panel displayed on the Sidebar 'Styles' deck.
Comment 2 V Stuart Foote 2019-07-03 13:23:57 UTC
Oh, and guess listbox customization of styles would apply to the droplist held in the 'Properties' deck also--not just the Toolbar instances (but I think they're using the same source now anyway.)
Comment 3 Massimo Medolla 2019-07-04 08:47:03 UTC
It would be nice to support user definited keyboard shortcut for styles.
Comment 4 Heiko Tietze 2019-07-12 10:00:19 UTC
I'm making this a duplicate of bug 101748, which asks for the same, being a dup itself of bug 91130 - smaller font list. We made a proposal that also has a favorite feature for this request. See https://design.blog.documentfoundation.org/2018/02/18/improvements-font-listing/ (and the discussion on the mentioned tickets too).

*** This bug has been marked as a duplicate of bug 101748 ***
Comment 5 V Stuart Foote 2019-07-12 12:28:30 UTC
(In reply to Heiko Tietze from comment #4)
> I'm making this a duplicate of bug 101748, which asks for the same, being a
> dup itself of bug 91130 - smaller font list. We made a proposal that also
> has a favorite feature for this request. See
> https://design.blog.documentfoundation.org/2018/02/18/improvements-font-
> listing/ (and the discussion on the mentioned tickets too).
> 
> *** This bug has been marked as a duplicate of bug 101748 ***

Not sure that is the right thing here. Both of those are about handling content of the Font drop lists with appropriate METAs.  This is about customization of the drop list selections of 'Styles'. similar mechanics but comparing "apples & oranges".

Issues of affecting customization of 'styles' would get lost.