Bug 126232 - In "Tools - Address Book Source" the Button "Address Data Source..." should be renamed
Summary: In "Tools - Address Book Source" the Button "Address Data Source..." should b...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: Address-Source
  Show dependency treegraph
 
Reported: 2019-07-04 21:17 UTC by Eugen
Modified: 2019-07-16 13:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugen 2019-07-04 21:17:17 UTC
Description:
The button in top right of the window has the caption "Address Book Source..."

Steps to Reproduce:
1. Open Writer
2. Goto "Tools - Address Book Source"


Actual Results:
See button in top right: "Address Book Source...". If you click on the Button you could add a new Address Book Source.
But the user can also think: "Hey, with this button I can configure the selected Address Book Source, which I selected in front"

Expected Results:
The button should has the caption "New..."


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2019-07-06 08:10:59 UTC
Eugen, I see "Address Data Source" button in top right corner of the dialog in

Version: 6.4.0.0.alpha0+
Build ID: 32bf6bec39748e64ca84a03e7488abe755747081
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-06-30_04:36:11
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

and I don't see menu Tools->Address Book Source at all in

Version: 6.2.4.2
Build ID: 1:6.2.4-0ubuntu0.19.04.1
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

And please add info from Help->About dialog here
Comment 2 Eugen 2019-07-06 19:56:50 UTC
Writer -> Tools -> Address Book Source... -> (Window opens) -> (top right) Address Data Source...

The button "Address Data Source.." at top right should has the caption "New...", because you add a new one.

Version: 6.2.4.2
Build ID: 1:6.2.4-0ubuntu0.19.04.1
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

Greetings
Eugen
Comment 3 QA Administrators 2019-07-07 03:40:48 UTC Comment hidden (obsolete)
Comment 4 Heiko Tietze 2019-07-12 10:33:36 UTC
(In reply to Eugen from comment #2)
> The button "Address Data Source.." at top right should has the caption
> "New...", because you add a new one.

Well, pedantic users may answer that accessing existing sources is not creating a new one. We could shorten it to "More", "Assign", or write "Address Wizard".
Comment 5 Eugen 2019-07-15 20:25:08 UTC
Hi,

I think your suggestion is a good idea.
"Assign" is my favorite

Greetings
Eugen
Comment 6 Heiko Tietze 2019-07-16 08:01:25 UTC
So let's do it.
Comment 7 Commit Notification 2019-07-16 13:24:31 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/07867134e3eba7c0faed88b06c0eebe9b43d8321%5E%21

tdf#126232 - Button "Address Data Source..." should be renamed

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.