Bug 126280 - PRINTING: Clicking Print window's Properties button crashes Calc - Crash in: ml1750u.DLL
Summary: PRINTING: Clicking Print window's Properties button crashes Calc - Crash in: ...
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-08 03:18 UTC by whong69
Modified: 2019-07-09 05:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["ml1750u.DLL"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description whong69 2019-07-08 03:18:59 UTC
This bug was filed from the crash reporting server and is br-ac43b667-5481-4894-921a-1b7aa5bb103c.
=========================================

In Calc with open spreadsheet...

a) Click File | Select Print | Print window opens
b) In General tab select a printer
c) Click on Properties button
d) Crash occurs

Note: Printer selected in this crash report was 'Samsung ML-1750 Series PCL 6 (USB)'.

However, crash also occurs if select the 'Print to File...' option.

No crash occurs if selected one of the following printer options:
- Fax
- Microsoft Print to PDF
- Microsoft XPS Document Writer
- OneNote

=========
Version: 6.2.4.2 (x64)
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 1 Xisco Faulí 2019-07-08 11:05:30 UTC
Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 whong69 2019-07-09 05:23:39 UTC
The issue is still present in Safe Mode when selecting the 'Print to File...' option and 'Samsung ML-1750 Series PCL 6 (USB)' option.

I did following steps:
- Start LibreOffice and select Help ▸ Restart in Safe Mode
    In the 'Enter Safe Mode' dialog select 'Restart'
    LibreOffice restarted and displayed the 'Safe Mode' dialog

- Select Continue in safe mode

- Test and see if the problem is gone.
    (If the problem persists, you can exit the safe mode because the user profile was not the cause of the problem.)

Test Result --> Problem persists in Safe Mode.

Note: I don't know if the Properties button ever worked previously as this is the first time I tried clicking on it and it crashed LibreOffice Calc.

======

Additional background info: Computer's Windows 7 was corrupted...  Win7 was re-installed and then Win10 installed on computer.  LibreOffice along with other apps were then re-installed. Basically, this is a fresh installation of Windows10 and apps.  Laser printer is connected via a print server on a router (TP-Link TL-WDR4300 N750) so it could be shared with other computers on home network.