Download it now!
Bug 126298 - FILEOPEN DOC: table row placement different in LO than Word. [Special fonts]
Summary: FILEOPEN DOC: table row placement different in LO than Word. [Special fonts]
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 126297 (view as bug list)
Depends on:
Blocks: DOC-Images
  Show dependency treegraph
 
Reported: 2019-07-09 07:08 UTC by Bill
Modified: 2020-04-23 16:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample documents for this bug. (2.75 MB, application/wps-office.doc)
2019-07-09 07:11 UTC, Bill
Details
Sample documents for this bug. (23.00 KB, application/wps-office.doc)
2019-07-09 07:13 UTC, Bill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bill 2019-07-09 07:08:27 UTC
Description:
The layout on two .doc documents are wrong.



Steps to Reproduce:
1.Opening the documents in LO and then in WPS or MS, will show the problems.
2.
3.

Actual Results:
Sample1: The second page of the resume doesn't start on the second page.
Sample2: The red heading is not in the right location and overlaps the typed area.

Expected Results:
Layed out properly.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Bill 2019-07-09 07:11:22 UTC
Created attachment 152659 [details]
Sample documents for this bug.
Comment 2 Bill 2019-07-09 07:13:16 UTC
Created attachment 152660 [details]
Sample documents for this bug.
Comment 3 BogdanB 2019-07-09 08:33:07 UTC
*** Bug 126297 has been marked as a duplicate of this bug. ***
Comment 4 Dieter 2019-07-09 11:44:24 UTC
Bill, I can confirm both with

Version: 6.2.5.2 (x64)
Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

and also with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: ae823e4633a76d13cebc6432b9e44b9b2862326b
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-26_23:06:07
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

but you should only use one bug report for one issue. So please file a new bug report for your second attachment.

I changed bug report for the first attachment to make the problem more clearly.


Doczument in attachment 152659 [details] contaions an image, which changes its position, when you open the document in LO
Comment 5 Justin L 2020-04-23 16:00:48 UTC
SAMPLE1-DeformedLayout.doc: the split tables are re-connected in LO with an extra CR added - at least that is what it looks like to me. That has been true since at least LO 3.5.

SAMPLE2-DeformedLayout.doc is a duplicate of bug 85435, where the line spacing of FIXED 28pt is set, but not being done in the layout.
Comment 6 Justin L 2020-04-23 16:11:13 UTC
Ahhh rats. It is all one table - my eyes deceived me.
So then it could be related to substituted fonts on my screen. Since this bug is now a mess, I'll close it since earlier it was focusing on the duplicate problem. If creating a new bug, it would be nice to have a minimal reproducer document using built-in fonts.