Download it now!
Bug 126333 - Show/hide comments button in the ruler became black when move mouse point on it
Summary: Show/hide comments button in the ruler became black when move mouse point on it
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.1 rc
Hardware: All All
: medium normal
Assignee: Jan-Marek Glogowski
URL:
Whiteboard: target:6.4.0 target:6.3.0.2 target:6.2.6
Keywords:
: 126376 (view as bug list)
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2019-07-10 17:43 UTC by Roman Kuznetsov
Modified: 2019-07-18 07:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example file with comment (9.08 KB, application/vnd.oasis.opendocument.text)
2019-07-10 17:44 UTC, Roman Kuznetsov
Details
Screenshot (30.92 KB, image/png)
2019-07-10 17:45 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-07-10 17:43:28 UTC
Description:
KDE5: Show/hide comments button in the ruler became black when move mouse point on it

Steps to Reproduce:
1. Open attach document
2. There is Show/hide comments button in the top ruler
3. Move mouse point on it
4. It became full black

Actual Results:
Show/hide comments button became black when move mouse point on it

Expected Results:
Show/hide comments button looks fine always


Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.3.0.1
ID сборки: 41ac97386aba908b6db860cfb4cfe2da871886ae
Потоков ЦП: 4; ОС:Linux 5.0; Отрисовка ИП: по умолчанию; VCL: kde5; 
Локаль: ru-RU (ru_RU.UTF-8); UI-Language: ru-RU
Calc: threaded
Comment 1 Roman Kuznetsov 2019-07-10 17:44:09 UTC
Created attachment 152711 [details]
Example file with comment
Comment 2 Roman Kuznetsov 2019-07-10 17:45:57 UTC
Created attachment 152712 [details]
Screenshot
Comment 3 Jan-Marek Glogowski 2019-07-10 17:58:11 UTC
Happens for me also with gtk3 and gen on master. What about Windows and MacOS?

If it's a general VCL problem, remove the blockers. Currently don't have time for bibisect myself. Maybe tomorrow, if noone beats me to it.
Comment 4 Commit Notification 2019-07-11 14:40:37 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2060f9598bc4480c44465abc9250b595c09af188%5E%21

tdf#126333 use dialog color for "button" highlight

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-07-12 13:15:02 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/54af6c8c873c3f6311806d210d5243b03e2d9fdf%5E%21

tdf#126333 use dialog color for "button" highlight

It will be available in 6.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-07-14 22:27:35 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/7ccc93d947ba3333cba6d99a03ed2d0c27b1983a%5E%21

tdf#126333 use dialog color for "button" highlight

It will be available in 6.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Adolfo Jayme 2019-07-18 07:14:22 UTC
*** Bug 126376 has been marked as a duplicate of this bug. ***