Bug Hunting Session
Bug 126393 - Hard to select a cell which contains only a hyperlink
Summary: Hard to select a cell which contains only a hyperlink
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.4.0
Keywords:
: 94248 123791 (view as bug list)
Depends on:
Blocks: Cell-Selection Hyperlink-Calc
  Show dependency treegraph
 
Reported: 2019-07-15 07:03 UTC by Samuel Mehrbrodt (CIB)
Modified: 2019-08-12 08:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2019-07-15 07:03:30 UTC
Insert a hyperlink in a cell in calc, e.g. http://example.com

Try to select that cell with the mouse.

Expected: Cell is selected when clicking on the hyperlink (ctrl-click open hyperlink)

Actual: Cell is *not* selected when clicking on the hyperlink. You have to select a nearby cell and move the selection with the keyboard.
Comment 1 Jacques Guilleron 2019-07-15 13:06:01 UTC
Hi Samuel,

I reproduce with
LO  6.4.0.0.alpha0+ (x86) Build ID: 719f4a93e46a6b397356dbb605d2867639ca3942
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: en-US (fr_FR); UI-Language: en-US Calc: CL
and
LO  3.5.3.2 Version ID : 235ab8a-3802056-4a8fed3-2d66ea8-e241b80
So probably inherited from OOo.
You have to find a blank zone(to the left or top) in a such formated cell.

Jacques
Comment 2 m.a.riosv 2019-07-15 20:57:02 UTC
If not the same, similar issue than in https://bugs.documentfoundation.org/show_bug.cgi?id=72266
Comment 3 Samuel Mehrbrodt (CIB) 2019-07-16 07:08:24 UTC
(In reply to m.a.riosv from comment #2)
> If not the same, similar issue than in
> https://bugs.documentfoundation.org/show_bug.cgi?id=72266

These two are not related. This is about Calc, not Writer.
Comment 4 Commit Notification 2019-07-17 07:04:45 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/22069f3d5d1c00551bd254d1002966e515295475%5E%21

tdf#126393 Select cell even when clicking on a hyperlink

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Samuel Mehrbrodt (CIB) 2019-08-06 14:57:07 UTC
*** Bug 94248 has been marked as a duplicate of this bug. ***
Comment 6 Samuel Mehrbrodt (CIB) 2019-08-12 08:58:37 UTC
*** Bug 123791 has been marked as a duplicate of this bug. ***