Bug 126403 - Revise layout of HTML color palette swatches
Summary: Revise layout of HTML color palette swatches
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Color-Palettes
  Show dependency treegraph
 
Reported: 2019-07-15 13:45 UTC by andreas_k
Modified: 2019-07-18 05:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
proposal arrangement of html color palett (11.73 KB, image/png)
2019-07-15 13:50 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2019-07-15 13:45:25 UTC
Description:
the existing html color palett is very complex and it's not that easy to find the correct color. Ordinary you want to use the HTML color name, but in libreoffice you see the name only with hover

Steps to Reproduce:
1. writer text color drop down menu

Actual Results:
all colors are in one frame but there is no separation between the different color areas (blue, green, pink, ...)

Expected Results:
each block should start with a new line
https://en.wikipedia.org/wiki/Web_colors


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 andreas_k 2019-07-15 13:50:30 UTC
Created attachment 152783 [details]
proposal arrangement of html color palett
Comment 2 andreas_k 2019-07-15 13:55:50 UTC
you can see an possible patch in gerrit.

https://gerrit.libreoffice.org/#/c/75405/

Change-Id: I8abac55a4d18a5bb77fb23b1592088f7972fcd24
Comment 3 V Stuart Foote 2019-07-15 15:20:59 UTC
I've no problem with reordering the swatches (note they've been alphabetical by name since X11 era, and now here they are grouped by color hue).

Also, I'm fine with adding the extra white space (#ffffff) swatches to give structure to the 12 column color rows.

I did not check color by color, but if ALL X11-SVG 1.0 colors in the HTML.soc are still named against their sRGB value--this would not disrupt the import of SVG or of Web pages. But none of the named colors can be dropped from the palette. 

I only object to duplicating a color & with a new color name positioned to the last column of each row.  I acknowledge the intent of making the color pick easier visually, but don't think it is necessary here.
Comment 4 Regina Henschel 2019-07-15 20:30:44 UTC
I see no advantage in the proposed change. On the contrary, many new names will be introduced for the color white and some other colors will also have double names. That is confusing. In addition, the new palette takes up more space and makes scrolling more likely.
Comment 5 Heiko Tietze 2019-07-16 07:59:27 UTC
(In reply to andreas_k from comment #2)
> you can see an possible patch in gerrit.

Correct patch is https://gerrit.libreoffice.org/#/c/75605/

The current palette was recreated based on https://en.wikipedia.org/wiki/Web_colors
Comment 6 Heiko Tietze 2019-07-18 05:31:48 UTC
We discussed the topic in the design meeting and decided to go with an extension: https://extensions.libreoffice.org/extensions/html-color-palette-update