Download it now!
Bug 126419 - Artifact around page after RTF paste special
Summary: Artifact around page after RTF paste special
Status: RESOLVED DUPLICATE of bug 105297
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2019-07-16 02:00 UTC by Aron Budea
Modified: 2019-07-16 18:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (top: buggy, bottom: correct) (67.86 KB, image/png)
2019-07-16 02:00 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2019-07-16 02:00:38 UTC
Created attachment 152800 [details]
Screenshot (top: buggy, bottom: correct)

- Start a new document.
- Enter some text, copy it to clipboard.
- Use paste special, and choose "Rich text formatting (RTF)".

=> Artifact over page shadow, also note the markers in the corners (see attached screenshot). Scrolling down and back up cleans the artifact.

Observed using LO 6.4.0.0.alpha0+ (49422a469646ad8be43ba828ca24c2484c26b9e8) & 4.2.0.4 / Windows 7 & Ubuntu 18.04.
No issue in LO 4.1.0.3.
=> regression
Comment 1 Aron Budea 2019-07-16 02:02:35 UTC
Bibisected to the following range with repo bibisect-42max. Had to skip a lot of commits in between, and I gave up.
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=c2530b02311c46529eed53ee688bf6c83ce4b86e..4dccfe055e93fe86ee7604c9137ae189cbc74823
Comment 2 Telesto 2019-07-16 18:28:39 UTC
Confirm.. However, I did report the same thing a long time ago: bug 105297
Comment 3 Aron Budea 2019-07-16 18:55:58 UTC
Fair enough, let's close as dupe, then.

*** This bug has been marked as a duplicate of bug 105297 ***