Download it now!
Bug 126462 - UI: 'autocorrect replacement table' bottom buttons positions have been changed
Summary: UI: 'autocorrect replacement table' bottom buttons positions have been changed
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-18 11:53 UTC by tommy27
Modified: 2019-07-23 12:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot from LibO 6.1.3 (80.30 KB, image/jpeg)
2019-07-18 11:53 UTC, tommy27
Details
screenshot from LibO 6.2.5 (78.16 KB, image/jpeg)
2019-07-18 11:54 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2019-07-18 11:53:15 UTC
the buttons at the bottom of the autocorrect replacement table (Tools/Autocorrect.../Autocorrect options) have alwayn been in this order:

Help  -  OK  - Cancel - Reset 
(see screenshot from LibO 6.1.3)

now the order is changed in:

Help  -  Reset  -  OK  - Cancel
(see screenshot from LibO 6.2.5)


I don't know if this change was intended or not...
anyway is causing me a lot of annoyance since I often automatically click on the second button, where OK has always been, but now I click on Reset.

changing the position of the OK button IMHO is not a good idea and alters daily routine with ad UI which has always been like that for  ages.

please revert to the original disposition
Comment 1 tommy27 2019-07-18 11:53:51 UTC
Created attachment 152859 [details]
screenshot from LibO 6.1.3
Comment 2 tommy27 2019-07-18 11:54:13 UTC
Created attachment 152860 [details]
screenshot from LibO 6.2.5
Comment 3 Telesto 2019-07-19 11:32:48 UTC
Repro, but as far I'm concerned by design. The button order was incoherent previously and in line with any gui guidance for Windows. See bug 126036
Comment 4 Heiko Tietze 2019-07-23 08:47:09 UTC
(In reply to Telesto from comment #3)
> Repro, but as far I'm concerned by design. The button order was incoherent
> previously and in line with any gui guidance for Windows. See bug 126036

Yes, this dialog was "welded" for 6.2 in patch https://gerrit.libreoffice.org/#/c/64507/ and thereby the button order corrected.
Comment 5 tommy27 2019-07-23 12:25:34 UTC
I preferred the old order... but that's it.
It seems I'll have to cope with the new one.

Thanks for clarifications.