Download it now!
Bug 126494 - conditional formatting icon color
Summary: conditional formatting icon color
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-07-21 13:44 UTC by Eric
Modified: 2019-09-04 15:55 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
icons as shown in conditional formatting dialog (25.46 KB, image/png)
2019-07-21 13:44 UTC, Eric
Details
request3d sample spreadsheet (6.70 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-07-22 21:34 UTC, Eric
Details
Screenshot with current master (60.62 KB, image/png)
2019-08-13 13:55 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric 2019-07-21 13:44:35 UTC
Created attachment 152890 [details]
icons as shown in conditional formatting dialog

Version: 6.2.5.2
Build ID: 20(Build:2)
CPU threads: 12; OS: Linux 5.1; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

In the 3 icon set, the up-arrow and down-arrow are both green
They should be different colors. 
I suggest the down-arrow icon should be red
Comment 1 m.a.riosv 2019-07-22 20:25:38 UTC
Please attach a sample ods file for test.
Comment 2 Eric 2019-07-22 21:34:10 UTC
Created attachment 152947 [details]
request3d sample spreadsheet

Attached is the blank spreadsheet in ods format as requested.
Select Menu->Format-Conditional->Icon_Set and when the dialog pops up look at the colored arrows. The Down-Arrow is green and the Up-arrow is also green. The down-arrow should be red IMHO
Comment 3 m.a.riosv 2019-07-22 23:18:47 UTC
Repro, seems the issue is with down arrow on 3,4,5 arrows.

It`s fine with:
Version: 6.3.1.0.0+ (x64)
Build ID: 95308943748bd650ee52e6e7570090f9c6a940b1
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-3, Time: 2019-07-22_08:07:50
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 382aceb80d3c0f420d51762e1f88eee2334ff11b
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-07-22_01:08:47
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
amd
Versión: 6.0.7.1 (x64)
Id. de compilación: 5d2cb2a5dd04fe174b336488731eb50bbb5faed3
Subprocs. CPU: 4; SO: Windows 10.0; Repres. IU: GL; 
Configuración regional: es-ES (es_ES); Calc: CL
Comment 4 Michael Weghorn 2019-08-13 13:55:48 UTC
Created attachment 153342 [details]
Screenshot with current master

I cannot reproduce with a current master build and a clean user profile on KDE Plasma:

Version: 6.4.0.0.alpha0+
Build ID: f101853c7dd1e9104ccda96e61a624a0c1496f9a
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kf5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Can you please try whether

1) changing icon-related settings in "Tools" -> "Options" -> "View" makes any difference?
2) this is still reproducible with a current daily build of master from [1]?
3) it happens with a fresh user profile as well?


[1] https://dev-builds.libreoffice.org/daily/master/
Comment 5 BogdanB 2019-08-13 17:59:02 UTC
it's red in
Version: 6.3.0.4
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Eric 2019-08-13 19:06:54 UTC
Interestingly, this works correctly with every "Icon Style" selection under "Tools->Options->View" except Karasa Jaga. I'll have to create a new user and try the other two items you requested so I'll post back later with my results
Comment 7 andreas_k 2019-08-19 06:22:03 UTC
Hi,

we (the icon designers) will have a look how to finaly fix it.
Comment 8 Rizal Muttaqin 2019-08-24 01:00:39 UTC
Not reproducible in latest build master (RED)

Version: 6.4.0.0.alpha0+
Build ID: 2bed8af91fc2654b9ed2432f969d32d5741a529b
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-08-21_09:30:10
Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 raal 2019-09-04 15:55:37 UTC
(In reply to Rizal Muttaqin from comment #8)
> Not reproducible in latest build master (RED)
> 
> Version: 6.4.0.0.alpha0+
> Build ID: 2bed8af91fc2654b9ed2432f969d32d5741a529b
> CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk2; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2019-08-21_09:30:10
> Locale: id-ID (id_ID.UTF-8); UI-Language: en-US
> Calc: threaded

Confirm Version: 6.4.0.0.alpha0+ (x64)
Build ID: 1bad7f0b19e47a41a1919573f80785ec62c611af
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win;