Bug Hunting Session
Bug 126510 - Delete drop down sections Separator, Position, Alignment, Scope in new Impress B&N dialog
Summary: Delete drop down sections Separator, Position, Alignment, Scope in new Impres...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: Impress-Bullet-Numbering-Dialog
  Show dependency treegraph
 
Reported: 2019-07-22 14:05 UTC by Roman Kuznetsov
Modified: 2019-07-29 10:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Drop down sections (55.65 KB, image/jpeg)
2019-07-22 14:17 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-07-22 14:05:57 UTC
Description:
Delete drop down sections Separator, Position, Alignment, Scope in new Impress B&N dialog.
It are always open by default and if we hide it then we don't win in height of dialog because we have hardcoded Level and Preview areas.
I suggest use simple labels Separator, Position, Alignment, Scope instead drop down sections

Steps to Reproduce:
-

Actual Results:
we have unused drop down sections in new B&N dialog

Expected Results:
we have simple labels instead drop down sections in new B&N dialog


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: c738be4de6886a0c96b7d10df7e78c8b2964c135
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2019-07-22 14:17:13 UTC
Created attachment 152940 [details]
Drop down sections
Comment 2 Heiko Tietze 2019-07-23 08:08:00 UTC
Yes, please do.
Comment 3 Commit Notification 2019-07-29 10:12:26 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/a34c898844abe9ad139d3ee22474726eed84351a%5E%21

Resolves: tdf#126510 - Expander sections are bad UX

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.