Bug 126550 - A wide image (4 x 1 inches), after rotated, cannot be properly aligned to the top left margin
Summary: A wide image (4 x 1 inches), after rotated, cannot be properly aligned to the...
Status: RESOLVED DUPLICATE of bug 115934
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-25 17:06 UTC by sstory
Modified: 2019-07-26 11:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sstory 2019-07-25 17:06:40 UTC
Description:
I inserted a wide image that was slightly over 4x1 inches into the first page of a Writer document. It was a logo to go to the left or right of the title text.  I rotated it 90 degrees. After that point I tried various ways to get the image to the top left margin. The image is set to Wrap optimally.  Dragging it just put the image back where it started. I tried changing the anchor to various options. I wanted it anchored to the page, so I finally left it there.  From Properties by changing alignment to Top and Left, it still did not work. It acted as though, even though the image is now tall and skinny due to rotation and a 1x4 instead of a 4x1, that it was trying to align based upon the non-rotated 4x1 image when anchoring.

Steps to Reproduce:
1. In Writer, add some title text (mine 18 words)
2. Set text to left justify
3. Insert an image 4 inches wide by 1 inch tall or any such aspect ratio
4. Set image Anchor to Page
5. Rotate that image 90 degrees
6. Set Wrap to Optimal Page Wrap
7. Try any way possible to get that image to be positioned to the top, left margin of the page.

Actual Results:
Dragging the image puts it right back on mouse release.  Some other options moves the top of the image completely off the page. Changing the Anchor type doesn't help. There seems to be no way to get that rotated image where you want it.

Rotating the image back to normal 4 wide, 1 tall, allows proper alignment easily.

Expected Results:
To be able to place the image as desired.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes

Version: 6.2.5.2
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 8; OS: Linux 3.10; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.utf8); UI-Language: en-US
Calc: threaded
Comment 1 Regina Henschel 2019-07-26 11:07:53 UTC
I think it is duplicate to bug 115934. Positioning uses the width and hight of the not rotated image.

*** This bug has been marked as a duplicate of bug 115934 ***