Download it now!
Bug 126719 - FILEOPEN DOCX Last bullet in custom colored paragraphs does not get the font color
Summary: FILEOPEN DOCX Last bullet in custom colored paragraphs does not get the font ...
Status: RESOLVED DUPLICATE of bug 64222
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2019-08-06 08:58 UTC by NISZ LibreOffice Team
Modified: 2019-09-19 08:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem in Writer (55.48 KB, image/png)
2019-08-06 08:59 UTC, NISZ LibreOffice Team
Details
Screenshot of the example file in current master (103.06 KB, image/png)
2019-09-08 23:33 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-08-06 08:58:46 UTC
Description:
Opening attachment #146597 [details] from bug #120548 after it was fixed displays bullets with the correct font color of the paragraph, except the last one. Adding more paragraphs in Word to the original file makes the new last bullet lose its font color and the former last one get it correctly.

Steps to Reproduce:
1.	Open attachment #146597 [details] 
2.	Notice that the bullets are appearing with red color of the paragraph, but the last one is black.


Actual Results:
The last paragraphs bullet is not red.

Expected Results:
It should have the red color too.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 382aceb80d3c0f420d51762e1f88eee2334ff11b
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-21_23:45:18
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

This started to happen in: 
Version: 6.3.0.0.alpha0+
Build ID: 00ac19068de5e120d1620a719aa64f1203c639ae
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded

Before that all bullets were black.
I wouldn’t call this a regression, since on the original screenshot of bug #120548  (attachment #145640 [details] ) it can be seen that the last bullet does not have a background fill either – that may be related to this.
Comment 1 NISZ LibreOffice Team 2019-08-06 08:59:26 UTC
Created attachment 153160 [details]
Screenshot of the problem in Writer
Comment 2 raal 2019-08-06 09:31:21 UTC
Confirm with Version: 6.4.0.0.alpha0+ (x64)
Build ID: 6eefac3b3744f806b0a35afbd0d9669d840118f4
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win;
Comment 3 Xisco Faulí 2019-08-07 15:46:52 UTC
Not reproduced in

Locale: ca-ES (ca_ES.UTF-8)

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 4 Xisco Faulí 2019-08-12 14:12:34 UTC
Also reproducible in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default;
Comment 5 Samuel Mehrbrodt (CIB) 2019-08-30 16:18:31 UTC
This seems to be fixed in current master.
Comment 6 Xisco Faulí 2019-09-03 07:26:11 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #5)
> This seems to be fixed in current master.

Still reproducible in

Version: 6.4.0.0.alpha0+
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Gabor Kelemen 2019-09-08 23:33:32 UTC
Created attachment 154031 [details]
Screenshot of the example file in current master

This seems to work now in:

Verzió: 6.4.0.0.alpha0+
Build az.: 001f739f1bca7607b0f8cf5f0c7e500dea70db44
CPU szálak: 4; OS: Linux 4.15; Felületmegjelenítés: alapértelmezett; VCL: gtk3; 
Területi beállítások: hu-HU (hu_HU.UTF-8); Felület nyelve: hu-HU
Calc: threaded
Comment 8 Gabor Kelemen 2019-09-09 08:43:32 UTC
A quick bibisect with bibisect-win64-6.4 shows that this started to work after 

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2c0d3ce5292b45a8897758508ee61801e4e8340d

*** This bug has been marked as a duplicate of bug 64222 ***
Comment 9 Xisco Faulí 2019-09-09 23:49:24 UTC
(In reply to Gabor Kelemen from comment #7)
> Created attachment 154031 [details]
> Screenshot of the example file in current master
> 
> This seems to work now in:
> 
> Verzió: 6.4.0.0.alpha0+
> Build az.: 001f739f1bca7607b0f8cf5f0c7e500dea70db44
> CPU szálak: 4; OS: Linux 4.15; Felületmegjelenítés: alapértelmezett; VCL:
> gtk3; 
> Területi beállítások: hu-HU (hu_HU.UTF-8); Felület nyelve: hu-HU
> Calc: threaded

I do confirm it

Version: 6.4.0.0.alpha0+
Build ID: f4f8bccbd4e2c3979a83d5b2f49e16a99a3a2016
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded