Bug 126726 - Crash swlo!SwNoTextNode::SetTitle
Summary: Crash swlo!SwNoTextNode::SetTitle
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2019-08-06 10:42 UTC by Telesto
Modified: 2021-11-16 09:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["CompareSwOutlineNodes::operator()(SwNode * const &,SwNode * const &)"]
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-08-06 10:42:18 UTC
Description:
Crash swlo!SwNoTextNode::SetTitle

Steps to Reproduce:
1. Open attachment 94647 [details] (bug 124739 and bug bug 75440)
2. CTRL+A
3. CTRL+C
4. CTRL+N
5. CTRL+V (2 times)
7. CTRL+Z (2 times)
9. CTRL+Y (2 times)
10. CTRL+V
11. CTRL+Z (2 times) -> Crash



Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: a675fe37abc134cc5cbf54385ca99c8d1417ce2b
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-26_09:09:34
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Xisco Faulí 2019-08-06 13:22:42 UTC
it crashes for me at step 9

Version: 6.4.0.0.alpha0+
Build ID: 967644f09b8b7abe3b86d1647820f14e0196f8b4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Xisco Faulí 2019-08-06 13:27:48 UTC
Also reproduced in


Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 3 Xisco Faulí 2019-08-06 13:32:44 UTC
Seems to be the same as bug 119241
Comment 4 Caolán McNamara 2021-11-15 21:11:38 UTC
Is this still reproducible, I was unable to reproduce it in master with comment #1
Comment 5 Xisco Faulí 2021-11-16 09:31:37 UTC
Not reproducible in

Version: 7.3.0.0.alpha1+ / LibreOffice Community
Build ID: e6968f0485cfb2f6c941d11c438386e14a47095d
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Closing as RESOLVED WORKSFORME