Bug 126735 - Change behavior of Previous/Next Change commands
Summary: Change behavior of Previous/Next Change commands
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.4
Keywords:
: 83950 (view as bug list)
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2019-08-06 19:27 UTC by Gabor Kelemen
Modified: 2021-06-04 12:11 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2019-08-06 19:27:07 UTC
Currently the Previous Change and Next Change commands in the Edit - Track Changes menu / Track Changes toolbar don't wrap around the list of tracked changes. 
Instead they do nothing when the cursor is at the first/last tracked change.

As it came up in bug #101977 it would be nice to change this behavior to wrap around the list of changes and start over at the first / last item.
This would be similar to what Word does and would make it harder to "forget" about changes in documents.
Comment 1 Heiko Tietze 2019-08-07 11:44:04 UTC
As commented on bug 101977 I cannot see a good reason why users want to stay at the current TC. It's on the agenda for the design meeting and I will discuss this at the ESC.
Comment 2 Juliet 2021-03-11 09:14:52 UTC
*** Bug 83950 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2021-04-07 10:23:30 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8e6203bd8f4390698f83a74a04f901437a9a61a3

tdf#126735 sw Next Change: cycle through tracked changes

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 NISZ LibreOffice Team 2021-05-06 11:46:14 UTC
Verified in:

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9df3aa7ea72d61462e430643f2a80906dce4e15b
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-GB
Calc: threaded

Thanks for fixing!
Comment 5 Commit Notification 2021-05-06 20:17:29 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/58720cad9ad9221d2bc0bb668beff18468d266d5

tdf#126226, tdf#126735 sw Next Change: cycle through tracked changes

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.