Download it now!
Bug 126762 - Table style lost on Saving to HTML
Summary: Table style lost on Saving to HTML
Status: RESOLVED DUPLICATE of bug 126883
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: HTML-Export
  Show dependency treegraph
 
Reported: 2019-08-08 07:18 UTC by Heiko Tietze
Modified: 2020-06-09 14:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document with one 2x2 table using default TS (8.37 KB, application/vnd.oasis.opendocument.text)
2020-06-09 10:36 UTC, Heiko Tietze
Details
Sample document _exported_ to html (4.14 KB, text/html)
2020-06-09 10:36 UTC, Heiko Tietze
Details
Sample document _saved as_ html (2.11 KB, text/html)
2020-06-09 10:36 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2019-08-08 07:18:03 UTC
* Table > Insert Table: Okay (using the Default Style) - this creates a table with black cell borders in Writer
* Export as HTML, open in Browser (checked with FF, Chromium) - no table

Running this with 5.2.7 works and the exported file looks like this:

   <td width="25%" style="border-top: 1px solid #000000; border-bottom: 1px solid #000000; ...

with master (and supposedly 6.1) we get

   <td width="50%" style="background: transparent" style="border-top: 1px solid #000000; ...

Removing the duplicate style entry manually solves the issue

   <td width="25%" style="border-top: 1px solid #000000; ...
Comment 1 Durgapriyanka 2019-08-13 21:00:39 UTC
Thank you for reporting the bug. 

I can reproduce this bug in (Chrome Browser)

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

But, No reproduction in (Chrome Browser)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Buovjaga 2020-06-08 18:47:28 UTC
Tried both with File - Export and File - Save as and it works fine for me.

Looking at the source, I would say you were NOT exporting to HTML, but using Save as... No duplication for me.

Please re-test

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 191288d6a7fb52b31038a21c4e71ee57ffa3bacd
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded
Comment 3 Heiko Tietze 2020-06-09 09:52:13 UTC
Works for me with File > Export... > html but not when using File > Save As > html.
Comment 4 Heiko Tietze 2020-06-09 10:04:47 UTC
(In reply to Heiko Tietze from comment #3)
> Works for me with File > Export... > html but not when using File > Save As
> > html.

Tested with

Version: 6.3.6.2
Build ID: 6.3.6-1
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: kde5; 
Locale: de-DE (en_US.UTF-8); UI-Language: en-US
Calc: threaded

and

Version: 7.1.0.0.alpha0+
Build ID: 85b68061a5a904ca82e5db40600af741d30f0bb8
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: gtk3
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 5 Heiko Tietze 2020-06-09 10:36:03 UTC
Created attachment 161798 [details]
Sample document with one 2x2 table using default TS
Comment 6 Heiko Tietze 2020-06-09 10:36:36 UTC
Created attachment 161799 [details]
Sample document _exported_ to html
Comment 7 Heiko Tietze 2020-06-09 10:36:57 UTC
Created attachment 161800 [details]
Sample document _saved as_ html
Comment 8 Buovjaga 2020-06-09 10:54:18 UTC
I was not using the menu, but the button. Now I can reproduce.

Steps:
1. Table - Insert Table
2. From Styles, select Default Table Style, Insert
3. File - Save as - HTML
Comment 9 Buovjaga 2020-06-09 14:29:21 UTC
Bibisected it and found it's a duplicate.

*** This bug has been marked as a duplicate of bug 126883 ***