Bug Hunting Session
Bug 126769 - Sidebar can't be collapsed clicking on the hide arrow
Summary: Sidebar can't be collapsed clicking on the hide arrow
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.6.2 release
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.4.0 target:6.3.1 target:6.2.7
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-08-08 13:42 UTC by Xisco Faulí
Modified: 2019-08-12 08:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-08-08 13:42:41 UTC
Steps to reproduce:
1. Open Writer
2. expand sidebar if it's not expanded
3. Collapse the sidebar

-> Nothing happens

Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: 63889d3d465e9b4292dd5bb630bd3394494c8a6d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-08-08 13:43:26 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=91d5ee8e0ce29c1389e015b01b2afa6795e2f601

author	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-07-29 10:09:11 +0200
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-07-29 12:18:13 +0200
commit	91d5ee8e0ce29c1389e015b01b2afa6795e2f601 (patch)
tree	7c1af72cf1b62d6cdb41d25a6f3529fb159dd0dc
parent	c1281e25c6de949c387ef42554a84040b86bc4b0 (diff)
Expand collapsed sidebar when calling XSidebarProvider::showDecks

Bisected with: bibisect-linux64-6.4 

Adding Cc: to Samuel Mehrbrodt
Comment 2 Xisco Faulí 2019-08-08 13:44:27 UTC
I can't reproduce it in

Versión: 6.3.0.3 (x86)
Id. de compilación: c75130c129d9c5e43b76e4f26881b3db8bdb5c91
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

Linux only ?
Comment 3 Xisco Faulí 2019-08-08 13:45:54 UTC
Just to be clear, the sidebar get collapsed if clicking on the icons on the right, but it's not if clicking on the black arrow ( hide ) on the left
Comment 4 Buovjaga 2019-08-08 13:54:58 UTC
Repro

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: 37fc9f51a8de11d40632e8cda17ccf1fa4b1f503
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 6 August 2019
Comment 5 Xisco Faulí 2019-08-08 13:56:51 UTC
The commit has been backported to 6.3 and 6.2. Don't think it's 'minor'
Comment 6 Commit Notification 2019-08-12 05:43:29 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2812610f4f39ed5892da08864893c758325d1d39%5E%21

tdf#126769 Sidebar can't be collapsed clicking on the hide arrow

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-08-12 07:58:06 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 2812610f4f39ed5892da08864893c758325d1d39
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Samuel, thanks for fixing this issue!
Comment 8 Commit Notification 2019-08-12 07:59:42 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/4a7d0b87373530d15deb2a5789841940ace31ea1%5E%21

tdf#126769 Sidebar can't be collapsed clicking on the hide arrow

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-08-12 08:01:07 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/379f36ab612ae8219df0813c60df7e52d71ca62d%5E%21

tdf#126769 Sidebar can't be collapsed clicking on the hide arrow

It will be available in 6.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.