Bug 126783 - FORMATTING Date format regresses to MM/DD/YYYY in overtyped data
Summary: FORMATTING Date format regresses to MM/DD/YYYY in overtyped data
Status: RESOLVED DUPLICATE of bug 126116
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: x86 (IA32) Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-08 18:04 UTC by W Sanders
Modified: 2019-08-09 07:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
dateformatexampple.ods representing this bug (29.31 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-08-08 18:08 UTC, W Sanders
Details

Note You need to log in before you can comment on or make changes to this bug.
Description W Sanders 2019-08-08 18:04:40 UTC
Description:
See attached sheet. Column "A" is formatted by column as MM/DD/YY. When I overtype (re-enter) a date in column "A", the resulting date is formatted as MM/DD/YYYY instead of MM/DD/YY. The issue persists when the column is reformatted as MM/DD/YY and the steps are repeated.

Data typed into an empty cell, however, gets formatted correctly.

This is a very recent regression, in the last two weeks Fedora 30 distro updates:

libreoffice.x86_64                               1:6.2.5.2-1.fc30                                      
libreoffice-base.x86_64                          1:6.2.5.2-1.fc30                                      
libreoffice-calc.x86_64                          1:6.2.5.2-1.fc30                                 

Version: 6.2.5.2
Build ID: 6.2.5.2-1.fc30
CPU threads: 4; OS: Linux 5.1; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

From: 

Steps to Reproduce:
See attached sheet. Column "A" is formatted by column as MM/DD/YY. When I overtype (re-enter) a date in column "A", the resulting date is formatted as MM/DD/YYYY instead of MM/DD/YY.

Actual Results:
MM/DD/YYYY

Expected Results:
MM/DD/YY


Reproducible: Sometimes


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 W Sanders 2019-08-08 18:08:55 UTC
Created attachment 153244 [details]
dateformatexampple.ods representing this bug
Comment 2 Oliver Brinzing 2019-08-09 07:14:32 UTC
i think this issue is a duolicate of:

Bug 126116 - Displayed form of date changes to dd-mm-yyyy when date is changed in cell with format dd-mm-yy

*** This bug has been marked as a duplicate of bug 126116 ***