Download it now!
Bug 126785 - All libreoffice programs are duplicating the inputs
Summary: All libreoffice programs are duplicating the inputs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:7.0.0 target:6.3.6 target:6.4.2
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-08-09 00:49 UTC by iuri
Modified: 2020-05-15 07:45 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
office log (427.98 KB, text/plain)
2019-10-29 18:52 UTC, Victor Silva
Details
office_log_new_manjaro (393.22 KB, text/x-log)
2019-10-29 22:30 UTC, Victor Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description iuri 2019-08-09 00:49:53 UTC
Description:
I can't use the libreoffice suit because all entries are duplicating. 

If I type "A", the result is "AA".

This problem extends in whole interface (dialog preferences, system comboboxes,...)

Steps to Reproduce:
1. Enter de program
2. Type anything everywhere

Actual Results:
duplicates the keyboard inputs

Expected Results:
doesn't duplicate the keyboard inputs


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Operational system: Manjaro Linux 64 bits
KDE Plasma: 5.16.3
KDE Frameworks: 5.60.0
Qt: 5.13.0
kernel: 4.19.60-1-MANJARO
Processors: 8 × Intel® Core™ i7-7700HQ CPU @ 2.80GHz
Comment 1 Xisco Faulí 2019-08-09 11:01:01 UTC
Does it work if you disable OpenGl ? -> https://wiki.documentfoundation.org/OpenGL

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 iuri 2019-09-16 22:59:12 UTC
Hi! 

Nothing change!
Comment 3 Xisco Faulí 2019-09-25 16:11:11 UTC
Hello iuri,
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 4 Victor Silva 2019-10-14 19:56:49 UTC
Hello Xisco, I can confirm it also hits fresh.

Additional Info:
Operational system: Manjaro Linux 64 bits
KDE Plasma: 5.16.5
KDE Frameworks: 5.62.0
Qt: 5.13.1
kernel: 4.19.78-1-MANJARO
Processors: 8 × Intel® Core™ i7-7700HQ CPU @ 2.80GHz
Comment 5 Victor Silva 2019-10-14 20:16:54 UTC
Hello Xisco, one thing just occured me both iuri and I are in Brazil and I assume  he is using ot-br as input maybe the bug is in the :
extra/libreoffice-fresh-br 6.3.2-1

package.
Comment 6 Victor Silva 2019-10-14 20:42:00 UTC
Just tried to use the packages in mate and now they seem to work so it might be kde related assuming iuri uses kde
Comment 7 Victor Silva 2019-10-15 21:48:19 UTC
Chenging the status as I've made the test on fresh as Xisco asked.
Comment 8 Xisco Faulí 2019-10-16 08:46:16 UTC
(In reply to Victor Silva from comment #7)
> Chenging the status as I've made the test on fresh as Xisco asked.

Does it work if you launch LibreOffice from command line with 'SAL_USE_VCLPLUGIN=gen soffice' ?
Comment 9 Victor Silva 2019-10-16 13:10:50 UTC
Yes it does!
Comment 10 Michael Weghorn 2019-10-16 14:07:17 UTC
I cannot reproduce here. Some questions:

1) What keyboard layout are you using?
2) Are you using any input methods, like IBUS or fcitx?
3) Is LibreOffice the only affected application, or are other KDE/Qt programs (e.g. Kate) also behaving weirdly?
4) What output does the command 'locale' produce?
5) Does anything change if you change the user interface and locale setttings in LibreOffice to "English (US)" in "Tools" -> "Options" -> "Language Settings" -> "Languages"?
Comment 11 Victor Silva 2019-10-16 15:15:10 UTC
>1) What keyboard layout are you using?
US-Int with dead keys

>2) Are you using any input methods, like IBUS or fcitx?
Nope

>3) Is LibreOffice the only affected application, or are other KDE/Qt programs >(e.g. Kate) also behaving weirdly?
No.

>4) What output does the command 'locale' produce?
locale
LANG=pt_BR.UTF-8
LC_CTYPE="pt_BR.UTF-8"
LC_NUMERIC=pt_BR.UTF-8
LC_TIME=pt_BR.UTF-8
LC_COLLATE="pt_BR.UTF-8"
LC_MONETARY=pt_BR.UTF-8
LC_MESSAGES="pt_BR.UTF-8"
LC_PAPER=pt_BR.UTF-8
LC_NAME=pt_BR.UTF-8
LC_ADDRESS=pt_BR.UTF-8
LC_TELEPHONE=pt_BR.UTF-8
LC_MEASUREMENT=pt_BR.UTF-8
LC_IDENTIFICATION=pt_BR.UTF-8
LC_ALL=

v5) Does anything change if you change the user interface and locale setttings in >LibreOffice to "English (US)" in "Tools" -> "Options" -> "Language Settings" -> >"Languages"?
No, same issue.
Comment 12 Victor Silva 2019-10-16 15:46:20 UTC Comment hidden (off-topic)
Comment 13 Michael Weghorn 2019-10-18 20:11:25 UTC Comment hidden (off-topic)
Comment 14 Michael Weghorn 2019-10-18 20:17:08 UTC
Is there any relevant output if you start LibreOffice via command line?
(in particular, using a daily build with debug symbols as available at [1] might give more information, which can be installed in parallel as described at [2])

[1] https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-dbg/
[2] https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 15 Victor Silva 2019-10-18 21:33:48 UTC
>If you're using the kde5/kf5 VCL plugin, font size should be according to what >you set in KDE Plasma system settings under "Fonts". I quickly verified this >works for me.
>However, that's another issue than what the original bug is about, so please open >a new bug report as needed if it doesn't for you.

Did not work for me. Before I open a new bug can you confirm this is the right setting?[1]https://imgur.com/a/8AJJajI


>Is there any relevant output if you start LibreOffice via command line?
Nope. I'm at work with very strict traffic shapping so I will try the builds at home but:

libreoffice-fresh 6.3.2-2 [instalado]
    LibreOffice branch which contains new features and program enhancements

has the issue.
Comment 16 Victor Silva 2019-10-18 21:36:06 UTC
Okay I just saw the bug was presented to a different version. So first of all sorry for my mistake. Can we try it again on 6.3.2.2 before I try the builds?
Comment 17 Victor Silva 2019-10-21 02:40:38 UTC
Okay seems I have problems to build LO in Manjaro with the script [1]:

At a first attempt I got:
./LOInstall.sh master_dbg~2019-10-09_11.54.09_LibreOfficeDev_6.4.0.0.alpha0_Linux_x86-64_archive_langpack_en-US.tar.gz 
##################################################################
LOInstall.sh: FATAL: Aborting! cannot guess language; please try calling me with langpack archive.

Usage: LOInstall.sh <INSTALLARCHIVE>

   try LOInstall.sh -h for description


So looking the source I changed the suffix removing the extra so it could match the pattern but it still did not work:


./LOInstall.sh LibreOfficeDev_6.4.0.0.alpha0_Linux_x86-64_archive_langpack_en-US.tar.gz 
Build    = 
Software = LibreOfficeDev
Version  = 6.4.0.0.alpha0
OS       = Linux
ARCH     = x86-64
PACKAGE  = archive
LANG     = en-US
PREFIX   = LibreOfficeDev_6.4.0.0.alpha0_Linux_x86-64
DIRNAME  = LibreOfficeDev_6.4.0.0.alpha0_Linux_x86-64
P.TYPE   = archive
##################################################################
LOInstall.sh: FATAL: Aborting! Unknown package type: archive

Usage: LOInstall.sh <INSTALLARCHIVE>

   try LOInstall.sh -h for description


[1]https://wiki.documentfoundation.org/User:Nnino/Scripts/LiboParaInstall.sh
Comment 19 Victor Silva 2019-10-22 14:45:24 UTC
Same result. Here is my history so you can track my steps:
  114  tar -vxzf LibreOffice_6.3.2_Linux_x86-64_deb.tar.gz
  115  cd LibreOffice_6.3.2.2_Linux_x86-64_deb/
  116  ls
  117  for i in ../DEBS/*.deb; do ar p $i data.tar.xz | tar -xJf - ; done
  118  ls
  119  cd DEBS/
  120  for i in ../DEBS/*.deb; do ar p $i data.tar.xz | tar -xJf - ; done
  121  ls
  122  cd opt/
  123  ls
  124  cd libreoffice6.3/
  125  ls
  126  cd program/
  127  ls
  128  ls
  129  vim bootstraprc 
  130  ls
  131  ls
  132  cd ..
  133  ls
  134  cd program/
  135  ls
  136  ./swriter 
  137  history
Comment 20 Michael Weghorn 2019-10-22 15:54:45 UTC
Any output on stdout/stderr?
Comment 21 Victor Silva 2019-10-22 16:05:18 UTC
Nope.
Comment 22 Victor Silva 2019-10-23 23:03:37 UTC
Xisco did help me in irc and starting with:
SAL_USE_VCLPLUGIN=gtk3 soffice

fixed all my issues both small letters and double input.I did record a video:
https://youtu.be/P--XXU2yPJk
showing the issue.
Comment 23 Michael Weghorn 2019-10-24 21:02:54 UTC
Thanks for the video. The video and comment 19 suggest that you're using version 6.3.2, which is a release build.
Debug builds generate more output, so trying again with a daily build with debug symbols (s. link in comment 14) *might* show more information on stderr.
Comment 24 Victor Silva 2019-10-25 19:40:02 UTC
Tried with no luck: master_dbg~2019-10-25_05.10.46_LibreOfficeDev_6.4.0.0.alpha1_Linux_x86-64_archive.tar.gz 
has no debs nor rpms into it. If I try to run:
/swriter 
./swriter: linha 4: /home/vfbsilva/Downloads/LibreOfficeDev_6.4.0.0.alpha1_Linux_x86-64_archive/program/soffice: Arquivo ou diretório inexistente

The suggested script also did not help:
./soffice.sh 
-----------------------------------------------
  Welcome to the Wonderful World of Frogs!
-----------------------------------------------

Starting LibreOffice
----------------------
  Helper Script Done
----------------------
./soffice.sh: linha 25: -env:UserInstallation=file:////home/vfbsilva/Downloads/LibreOfficeDev_6.4.0.0.alpha1_Linux_x86-64_archive: Arquivo ou diretório inexistente
Comment 25 Michael Weghorn 2019-10-25 22:57:56 UTC
This works for me:

Download:
    wget https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-dbg/2019-10-25_05.10.46/master_dbg~2019-10-25_05.10.46_LibreOfficeDev_6.4.0.0.alpha1_Linux_x86-64_archive.tar.gz

extract:
    tar xvf master_dbg~2019-10-25_05.10.46_LibreOfficeDev_6.4.0.0.alpha1_Linux_x86-64_archive.tar.gz 

run:
    ./LibreOfficeDev_6.4.0.0.alpha1_Linux_x86-64_archive/program/soffice --writer
Comment 26 Victor Silva 2019-10-28 16:09:10 UTC
(In reply to Michael Weghorn from comment #25)
> This works for me:
> 
> Download:
>     wget
> https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-
> dbg/2019-10-25_05.10.46/master_dbg~2019-10-25_05.10.46_LibreOfficeDev_6.4.0.
> 0.alpha1_Linux_x86-64_archive.tar.gz
> 
> extract:
>     tar xvf
> master_dbg~2019-10-25_05.10.46_LibreOfficeDev_6.4.0.0.alpha1_Linux_x86-
> 64_archive.tar.gz 
> 
> run:
>     ./LibreOfficeDev_6.4.0.0.alpha1_Linux_x86-64_archive/program/soffice
> --writer


Executed the commands above and got the following log, duplicated lines were removed:


(In reply to Michael Weghorn from comment #25)
> This works for me:
> Download:
>     wget
> https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-
> dbg/2019-10-25_05.10.46/master_dbg~2019-10-25_05.10.46_LibreOfficeDev_6.4.0.
> 0.alpha1_Linux_x86-64_archive.tar.gz
> extract:
>     tar xvf
> master_dbg~2019-10-25_05.10.46_LibreOfficeDev_6.4.0.0.alpha1_Linux_x86-
> 64_archive.tar.gz
>
> run:
>     ./LibreOfficeDev_6.4.0.0.alpha1_Linux_x86-64_archive/program/soffice
> --writer
Executed the commands above and got the following log:


warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Size5-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Size6-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Symbols-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Variants-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Size4-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Size3-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Size2-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Size1-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Shapes-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Script-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_SansSerif-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Alphabets-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_NonUnicode-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Normal-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Operators-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Monospace-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Misc-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Marks-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Main-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Latin-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Fraktur-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_DoubleStruck-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Asana-Math/woff/AsanaMathJax_Arrows-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Size3-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Main-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Marks-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Misc-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Monospace-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_NonUnicode-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Normal-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Operators-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_SansSerif-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Script-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Shapes-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Size1-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Size2-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Size4-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Size5-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Size6-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Size7-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Symbols-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Variants-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Alphabets-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Arrows-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_DoubleStruck-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Fraktur-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Latin-Modern/woff/LatinModernMathJax_Latin-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_AMS-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Caligraphic-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Caligraphic-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Fraktur-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Fraktur-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Main-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Main-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Main-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Math-BoldItalic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Math-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Math-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_SansSerif-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_SansSerif-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_SansSerif-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Script-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Size1-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Size2-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Size3-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Size4-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Typewriter-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Vector-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/TeX/woff/MathJax_Vector-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Symbols-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Variants-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Alphabets-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Arrows-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Fraktur-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Main-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Marks-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_NonUnicode-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Normal-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Operators-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Script-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Size1-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Size2-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Size3-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Shapes-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Size4-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Neo-Euler/woff/NeoEulerMathJax_Size5-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Alphabets-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Alphabets-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Alphabets-BoldItalic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Alphabets-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Arrows-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Arrows-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_DoubleStruck-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_DoubleStruck-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_DoubleStruck-BoldItalic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_DoubleStruck-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Fraktur-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Fraktur-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Main-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Main-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Main-BoldItalic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Marks-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Marks-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Marks-BoldItalic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Marks-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Misc-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Misc-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Misc-BoldItalic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Misc-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Monospace-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Normal-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Normal-BoldItalic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Normal-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_SansSerif-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Script-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Script-BoldItalic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: /STIXMathJax_Size4-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Size5-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Symbols-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Symbols-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Variants-Italic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Variants-BoldItalic.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Variants-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/STIX-Web/woff/STIXMathJax_Variants-Bold.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Fraktur-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Variants-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Symbols-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Size6-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Size4-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Alphabets-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Arrows-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_DoubleStruck-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Latin-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Main-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Marks-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Misc-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Monospace-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_NonUnicode-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Normal-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Operators-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_SansSerif-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Script-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Shapes-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Size1-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Size2-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Size3-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Pagella/woff/GyrePagellaMathJax_Size5-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Symbols-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Size3-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Monospace-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Alphabets-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Arrows-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_DoubleStruck-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Fraktur-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Latin-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Main-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Marks-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Misc-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Size5-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_NonUnicode-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Normal-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Operators-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_SansSerif-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Script-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Shapes-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Size1-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Size2-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Size6-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Size4-Regular.woff": 6
warn:vcl.fonts:23624:23624:vcl/unx/generic/fontmanager/fontmanager.cxx:664: Could not OpenTTFont "/usr/share/fonts/mathjax2/HTML-CSS/Gyre-Termes/woff/GyreTermesMathJax_Variants-Regular.woff": 6
warn:i18nlangtag:23624:23624:i18nlangtag/source/languagetag/languagetag.cxx:1397: LanguageTagImpl::convertLocaleToLang: with bAllowOnTheFlyID invalid 'en-AU-large'
warn:i18nlangtag:23624:23624:i18nlangtag/source/languagetag/languagetag.cxx:1397: LanguageTagImpl::convertLocaleToLang: with bAllowOnTheFlyID invalid 'en-CA-large'
warn:i18nlangtag:23624:23624:i18nlangtag/source/languagetag/languagetag.cxx:1397: LanguageTagImpl::convertLocaleToLang: with bAllowOnTheFlyID invalid 'en-GB-large'
warn:i18nlangtag:23624:23624:i18nlangtag/source/languagetag/languagetag.cxx:1397: LanguageTagImpl::convertLocaleToLang: with bAllowOnTheFlyID invalid 'en-US-large'
warn:sfx.view:23624:23624:sfx2/source/view/viewfrm.cxx:3192: SID_SIDEBAR state requested, but no task pane child window exists for this ID!
warn:xmloff.core:23624:23624:xmloff/source/core/xmlimp.cxx:785:
warn:xmloff.core:23624:23624:xmloff/source/core/xmlimp.cxx:785: SvXMLImport::endElement: popped context has wrong lname
warn:vcl.schedule.deinit:23624:23624:vcl/source/app/scheduler.cxx:175: DeInit task: Timer a: 1 p: 1 framework::AutoRecovery m_aTimer 600000ms (0x3f3a048)
warn:vcl.schedule.deinit:23624:23624:vcl/source/app/scheduler.cxx:175: DeInit task: Timer a: 1 p: 1 graphic::Manager maSwapOutTimer 10000ms (0x7f2c0b28f4c8)
warn:vcl.schedule.deinit:23624:23624:vcl/source/app/scheduler.cxx:196: DeInit active tasks: 2 (ignored: 0)
warn:unotools.config:23624:23624:unotools/source/config/configmgr.cxx:140: ConfigManager not empty
Comment 27 Michael Weghorn 2019-10-29 08:36:20 UTC
(In reply to Victor Silva from comment #26)
> Executed the commands above and got the following log, duplicated lines were
> removed:

Thanks. (For the future: Attaching a text file with the log helps to keep a better overview here. :))

> warn:i18nlangtag:23624:23624:i18nlangtag/source/languagetag/languagetag.cxx:
> 1397: LanguageTagImpl::convertLocaleToLang: with bAllowOnTheFlyID invalid
> 'en-AU-large'
> warn:i18nlangtag:23624:23624:i18nlangtag/source/languagetag/languagetag.cxx:
> 1397: LanguageTagImpl::convertLocaleToLang: with bAllowOnTheFlyID invalid
> 'en-CA-large'
> warn:i18nlangtag:23624:23624:i18nlangtag/source/languagetag/languagetag.cxx:
> 1397: LanguageTagImpl::convertLocaleToLang: with bAllowOnTheFlyID invalid
> 'en-GB-large'
> warn:i18nlangtag:23624:23624:i18nlangtag/source/languagetag/languagetag.cxx:
> 1397: LanguageTagImpl::convertLocaleToLang: with bAllowOnTheFlyID invalid
> 'en-US-large'

These messages may or may not be related: Do you have an idea where those invalid values like "en-AU-large" etc. come from? They don't happen to be used in my setup. Can you attach the output of the "env" command?

Otherwise, as you mentioned in comment 5 that this may be related to the locale setup: Can you also reproduce this if you try with a system/user that uses en-US locale (if you have the chance to test this)?
Or can you explain how to set up a system from scratch in which this can be reproduced (or even provide a VM or sth else)?
Comment 28 Michael Weghorn 2019-10-29 08:37:57 UTC
And just to double-check: Did you type something when running the debug build for the boutput in comment 26 and were the typed letters doubled there as well?
Comment 29 Victor Silva 2019-10-29 18:52:10 UTC
Created attachment 155402 [details]
office log
Comment 30 Victor Silva 2019-10-29 19:01:14 UTC
(In reply to Michael Weghorn from comment #28)
> And just to double-check: Did you type something when running the debug
> build for the boutput in comment 26 and were the typed letters doubled there
> as well?

Yes I did and yes they were doubled.

>These messages may or may not be related: Do you have an idea where those >invalid >values like "en-AU-large" etc. come from? They don't happen to be used >in my >setup. Can you attach the output of the "env" command?
SHELL=/bin/bash
SESSION_MANAGER=local/mordor:@/tmp/.ICE-unix/1236,unix/mordor:/tmp/.ICE-unix/1236
WINDOWID=50331655
COLORTERM=truecolor
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session1
CONDA_EXE=/opt/miniconda3/bin/conda
_CE_M=
PKG_CONFIG_PATH=/opt/opencv3/lib/pkgconfig/
LANGUAGE=pt_BR
SHELL_SESSION_ID=229c5069a6f14944941ab233d5d9560b
DESKTOP_SESSION=/usr/share/xsessions/plasma
GTK_RC_FILES=/etc/gtk/gtkrc:/home/vfbsilva/.gtkrc:/home/vfbsilva/.config/gtkrc
GTK_MODULES=canberra-gtk-module
XDG_SEAT=seat0
PWD=/home/vfbsilva
XDG_SESSION_DESKTOP=KDE
LOGNAME=vfbsilva
XDG_SESSION_TYPE=x11
XAUTHORITY=/tmp/xauth-1002-_0
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/vfbsilva/.gtkrc-2.0:/home/vfbsilva/.config/gtkrc-2.0
HOME=/home/vfbsilva
LANG=pt_BR.UTF-8
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.axa=00;36:*.oga=00;36:*.spx=00;36:*.xspf=00;36:
XDG_CURRENT_DESKTOP=KDE
KONSOLE_DBUS_SERVICE=:1.32
KONSOLE_DBUS_SESSION=/Sessions/2
PROFILEHOME=
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
KONSOLE_VERSION=190802
KDE_SESSION_UID=1002
XDG_SESSION_CLASS=user
TERM=xterm-256color
_CE_CONDA=
USER=vfbsilva
CUDA_PATH=/opt/cuda
COLORFGBG=15;0
CONDA_SHLVL=0
KDE_SESSION_VERSION=5
PAM_KWALLET5_LOGIN=/run/user/1002/kwallet5.socket
DISPLAY=:0
SHLVL=1
XDG_VTNR=1
XDG_SESSION_ID=2
QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
CONDA_PYTHON_EXE=/opt/miniconda3/bin/python
MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins
LC_CTYPE=pt_BR.UTF-8
XDG_RUNTIME_DIR=/run/user/1002
QT_AUTO_SCREEN_SCALE_FACTOR=0
XCURSOR_THEME=breeze_cursors
XDG_DATA_DIRS=/home/vfbsilva/.local/share/flatpak/exports/share:/var/lib/flatpak/exports/share:/usr/local/share:/usr/share:/var/lib/snapd/desktop
KDE_FULL_SESSION=true
PATH=/opt/miniconda3/condabin:/home/vfbsilva/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/opt/cuda/bin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/var/lib/snapd/snap/bin
KONSOLE_PROFILE_NAME=Shell
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1002/bus
MAIL=/var/spool/mail/vfbsilva
_=/usr/bin/env


>Otherwise, as you mentioned in comment 5 that this may be related to the locale >setup: Can you also reproduce this if you try with a system/user that uses enUS >locale (if you have the chance to test this)?
>Or can you explain how to set up a system from scratch in which this can be >reproduced (or even provide a VM or sth else)?
I tried to change my locale to enUS and the bug was also present. I set all language to enUS in KDE. My bandwidth at work is ridiculous so it takes me 3 hours to dl the manjaro iso. as soon as I get it  Iwill setup a VM.
Comment 31 Victor Silva 2019-10-29 22:30:41 UTC
Created attachment 155404 [details]
office_log_new_manjaro
Comment 32 Victor Silva 2019-10-29 22:31:49 UTC
New install wors. Logs added, not sure about what to do now Since the error appeared in my new profile on my main install . I will do further testing rebooting the machine and saving/opening docs tommorow.
Comment 33 Victor Silva 2019-10-30 20:24:27 UTC
https://ask.libreoffice.org/en/question/192896/double-letters-in-manjaro/

At this point I believe this is a manjaro issue. But what?
Comment 34 Victor Silva 2019-10-30 20:34:14 UTC
Just found a anther report on the manjaro forum with an important behaviour:
https://forum.manjaro.org/t/libreoffice-double-typing/83379/19

Quoting:
"Just to add: I'm also using the Brazilian locale and had this problem since I was previously using Antergos, when libreoffice-fresh was 6.2. At the time, my workaround was to install libreoffice-still, which was 6.1.
Recently I tried again with Manjaro, Plasma, and the issue does happen every time.
I then installed some other DE to test - Budgie. If i login to Budgie, the error is not present.
The funny thing is that after logging into Budgie, if I logout and login to Plasma, the issue is gone. But, rebooting the PC and logging in to Plasma again shows the issue again.
As a workaround I've switched to Gnome, but I want to use Plasma again!
Will try those env variables."
Comment 35 Michael Weghorn 2019-10-31 21:34:09 UTC
It's hard to tell what the problem is without being able to observe it. This may or may not be under the control of Libreoffice...

https://forum.manjaro.org/t/libreoffice-double-typing/83379/6 mentions that there is some connection with onscreen keyboard. Can you observe that, too?
Comment 36 Victor Silva 2019-10-31 23:04:55 UTC
Michael I did some talking at #kde and the folks over there commented the issue might be on the KF5 VCL plugin. Seems buble develops it> I looked in github and found you also worked on this: https://github.com/LibreOffice/core/blob/master/vcl/README

That would explain why "SAL_USE_VCLPLUGIN=gen soffice" did work. Despite the letters being awefully small.
Comment 37 Michael Weghorn 2019-11-01 18:09:54 UTC
(In reply to Victor Silva from comment #36)
> Michael I did some talking at #kde and the folks over there commented the
> issue might be on the KF5 VCL plugin.

Yes, if there's something on LibreOffice side, that must be in the kf5 plugin. However, without knowing when the issue happens and without the possibility to reproduce it, it's hard to impossible to analyse and do anything about it.

If you can find out more about this (e.g. what steps you need to do on your other computer to make the issue occur there as well), that might help. At least for myself, I unfortunately feel unable to do anything about it at the moment...
Comment 38 Victor Silva 2019-11-19 22:56:37 UTC
I just found out that cedilla "ç" is not duplicated can it be a clue?
Comment 39 Michael Weghorn 2020-02-12 09:04:30 UTC
While looking at tdf#122053, I realized that I can reproduce the issue when I install the Orca screen reader and enable it in Plasma settings. I'm running Debian testing with KDE Plasma as desktop environment.

Version: 7.0.0.0.alpha0+
Build ID: d41d7ecb60fb38204fafcb1aa4595992721855e6
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Works fine when using the gtk3 VCL plugin instead.
Comment 40 Michael Weghorn 2020-02-14 17:03:25 UTC
Now that I can reproduce, I've taken a first look and think I have a rough understanding on what is happening.
Will hopefully get to implement a fix sometime next week.
Comment 41 Commit Notification 2020-02-17 11:42:03 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/034f56015c1c7a61faede33fb5306f63b5585632

tdf#126785 qt5: Ignore external QEvent::ShortcutOverride

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 42 Michael Weghorn 2020-02-17 11:43:40 UTC
The commit from comment 41 fixes the issue for my case when Orca is enabled.
Should your issue still appear with a daily master build from tomorrow or later, please leave a comment here and reopen.

Backports for 6.3 and 6.4 branches pending in Gerrit.
Comment 43 Commit Notification 2020-02-17 14:49:01 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/cc4f16ca02c97847d05ee6479ae138a47db148f7

tdf#126785 qt5: Ignore external QEvent::ShortcutOverride

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 44 Commit Notification 2020-02-18 08:05:57 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/1260b71c6796f12053cddd4c7a8f3f727fdf1890

tdf#126785 qt5: Ignore external QEvent::ShortcutOverride

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 45 Alexander Volkov 2020-05-14 17:28:44 UTC
Here is the fix in Qt: https://codereview.qt-project.org/c/qt/qtbase/+/295892
Comment 46 Michael Weghorn 2020-05-15 06:00:32 UTC
(In reply to Alexander Volkov from comment #45)
> Here is the fix in Qt: https://codereview.qt-project.org/c/qt/qtbase/+/295892

Thanks for taking care of this!

Note, however, that the logic was inverted in a follow-up patch to ignore non-spontaneous events instead:
https://git.libreoffice.org/core/+/69e708868f6046cada955a16bca966370ce3218a%5E%21

The initial version had actually broken input for non-a11y setups, s. tdf#130794.

Do I understand correctly that we would therefore completely lose input for the a11y case with the Qt patch in place (since Qt no longer sends spontaneous events, and we ignore the non-spontaneous ones)?

In other words, should we adapt LibreOffice to ignore those events only for Qt versions that don't have your Qt fix yet (once it is in) by adding a corresponding check for the runtime Qt version?
Comment 47 Alexander Volkov 2020-05-15 07:45:43 UTC
Yes, runtime check will be required.