Download it now!
Bug 126791 - StartCenter: previews of .xlsx files are black (gen/gtk)
Summary: StartCenter: previews of .xlsx files are black (gen/gtk)
Status: RESOLVED DUPLICATE of bug 125461
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 126884 (view as bug list)
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2019-08-09 11:25 UTC by Xisco Faulí
Modified: 2019-09-09 23:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
How it looks (45.74 KB, image/png)
2019-08-09 11:25 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-08-09 11:25:31 UTC
Created attachment 153258 [details]
How it looks

See attached image

reproduced in

Version: 6.4.0.0.alpha0+
Build ID: d4a70ecf61b016a32caef015eea127d13b357cf7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-08-09 11:26:30 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d43c6fa220524a09c0b24cbb5bc03c4456cd2515

author	Heiko Tietze <tietze.heiko@gmail.com>	2019-07-29 12:03:19 +0200
committer	Heiko Tietze <heiko.tietze@documentfoundation.org>	2019-08-06 09:26:08 +0200
commit	d43c6fa220524a09c0b24cbb5bc03c4456cd2515 (patch)
tree	0e67a4393b30b2ca5185a30511ce5a7a275364da
parent	600025475630c59c53a9086ba6d95124416725b3 (diff)
Resolves: tdf#125756 - MIME type icons on start center's thumbnails

Bisected with: bibisect-linux64-6.4 

Adding Cc: to Heiko Tietze
Comment 2 Xisco Faulí 2019-08-09 11:39:09 UTC
Also reproducible with gtk
Comment 3 Heiko Tietze 2019-08-12 08:43:13 UTC
I get the same error (Unsupported BitCount!) and a black thumbnail when commenting out my changes. Please check it, Xisco.
Comment 4 Heiko Tietze 2019-08-12 15:30:53 UTC
Likely a duplicate; if not please reopen.

*** This bug has been marked as a duplicate of bug 125461 ***
Comment 5 Xisco Faulí 2019-08-13 09:12:05 UTC
(In reply to Heiko Tietze from comment #3)
> I get the same error (Unsupported BitCount!) and a black thumbnail when
> commenting out my changes. Please check it, Xisco.

Not the case here, I've just reverted your commit and the thumbnail is correctly displayed... it happens with any XLSX to me
Comment 6 Heiko Tietze 2019-08-13 09:43:01 UTC
Tomaz, please have a look.
Comment 7 Xisco Faulí 2019-08-13 15:16:12 UTC
*** Bug 126884 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2019-09-09 23:31:01 UTC
Fixed by https://git.libreoffice.org/core/+/966a51dfc63e2a783282dfd0379bf5c987b1e136%5E%21.
Closing as duplicate of bug 125461

*** This bug has been marked as a duplicate of bug 125461 ***