Download it now!
Bug 126797 - Half of the pages are missing caused complex table which isn't splitted properly most of the time, possible caused by nested tables
Summary: Half of the pages are missing caused complex table which isn't splitted prope...
Status: RESOLVED DUPLICATE of bug 35449
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2019-08-09 16:52 UTC by Telesto
Modified: 2019-12-09 18:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Proper layout (PDF) (95.49 KB, application/pdf)
2019-08-09 16:53 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-08-09 16:52:41 UTC
Description:
Half of the page are missing caused complex table. Layout can get jumpy or layout loop is possible, but hard to give proper steps

Steps to Reproduce:
1. Attachment 152466 [details]
2. Wait 15 seconds after the pages appear 
3. Page counter will show 38 pages. 
4. It actually are 69 pages (PDF of the same file attached; created with LibO 6.3.0.4 & PDF printer)

Note: all sorts of weirdness is possible with this document in older versions of LibreOffice (crashes etc). 

Actual Results:
The initial load will give 38 pages. Except when scrolling down to bottom (by clicking on the bottom of the vertical scroll bar and/or scrolling down quickly after file open, while the table layouting is still in progress. In that case with some luck you end up with the full document (proper) document.

If the full document is shown 
-> exported to PDF -> broken 
-> Printing (to PDF) -> fine 

Expected Results:
Layout as in PDF of something matching it for the most part


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in:
Versie: 6.3.0.4 (x86)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU-threads: 4; Besturingssysteem: Windows 6.3; UI-render: standaard; VCL: win; 
Locale: nl-NL (nl_NL); UI-taal: nl-NL
Calc: CL
Comment 1 Telesto 2019-08-09 16:53:20 UTC
Created attachment 153271 [details]
Proper layout (PDF)
Comment 2 Jean-Baptiste Faure 2019-08-18 19:46:43 UTC
I see only from 6 to 9 pages depending on the version of LO I use (6.1, 6.2, 6.3 and master).
Could it be possible to have a test file anonymized without replacing spaces by X as other characters so that we have not paragraphs with only one word?

Best regards. JBF
Comment 3 Durgapriyanka 2019-08-23 21:58:27 UTC
Thank you for reporting the bug. 

I can see only 11 pages in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

and 

only 4 pages in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Dieter 2019-08-30 07:51:41 UTC
7 pages in 

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

I think, the problem with this file is obvious => NEW
Comment 5 Timur 2019-12-09 18:04:28 UTC
Repro 6.5+.
If table text selected and cleared direct formatting, then 65 pages. And that would be right, because in PDF of 69 there are empty areas due to wrong reflow.
Based on that ,I's say this is a duplicate. 
Feel free to set back New if explained not to be.

*** This bug has been marked as a duplicate of bug 35449 ***