Download it now!
Bug 126830 - Icons not showing in menus
Summary: Icons not showing in menus
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.1 target:7.1....
Keywords: bibisected, bisected, regression
: 127106 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-11 17:51 UTC by BogdanB
Modified: 2020-10-11 11:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (83.53 KB, image/png)
2020-10-05 07:15 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BogdanB 2019-08-11 17:51:25 UTC
Description:
After checking in Tools - Options - View - Show Icons in menus I dont see any icon.


Steps to Reproduce:
1.After checking in Tools - Options - View - Show Icons in menus I dont see any icon.

2.
3.

Actual Results:
No icon

Expected Results:
Icons should be visibile.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.3.0.4
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

Ubuntu Budgie 18.04
Comment 1 BogdanB 2019-08-11 17:52:10 UTC
Some suggest a regression, so I will try to bibisect with 6.3
Comment 2 Jean-Baptiste Faure 2019-08-11 18:40:54 UTC
Yes, that is a regression because it works in LO 6.2.5 under Ubuntu 18.04 but not in LO 6.3.1.0+ nor in current master.

Best regards. JBF
Comment 3 raal 2019-08-16 16:33:15 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin ; Could you possibly take a look at this one?
Thanks

5bf61ce1eb7304a72c9bdc6562355ea76071d5e2 is the first bad commit
commit 5bf61ce1eb7304a72c9bdc6562355ea76071d5e2
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Mon Apr 29 08:47:23 2019 +0200

    source sha:9eae555542ce01cb289b9e736454abcf835b8394

author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-04-28 09:54:42 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-04-29 08:30:26 +0200
commit	9eae555542ce01cb289b9e736454abcf835b8394 (patch)
tree	7e6f1d44f609ebcf05e3675ea8f10e41652cc078
parent	8647288180806f8515bf2548db7280cbc657eaf3 (diff)
speed up gtk menu construction at startup
Comment 4 Commit Notification 2019-08-19 09:26:09 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/35b41150e84940e87b9d961b6b402e3e060d6b8b%5E%21

tdf#126830 Icons not showing in menus

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-08-20 09:45:22 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/97fefe2e0870c7e62d39ba1e82e1c276c8f64ced%5E%21

tdf#126830 Icons not showing in menus

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-08-21 15:41:38 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-1":

https://git.libreoffice.org/core/+/635c4fc49cd48d024bf7a81acd5b36a169221510%5E%21

tdf#126830 Icons not showing in menus

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 BogdanB 2019-08-23 14:41:53 UTC
*** Bug 127106 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2020-09-30 14:56:20 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9e129e8557370207f784cba0f40643044ead88be

Restore the fix for tdf#126830

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-09-30 18:12:19 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/800baa9c60d8fb7b4ed8cf8ae0ba7b6b68c69c9c

Restore the fix for tdf#126830

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-10-04 13:05:58 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/fa85f4c9dfdef681dbbcb56845b0c19c6ef1ff52

Restore the fix for tdf#126830

It will be available in 6.4.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 BogdanB 2020-10-05 07:15:02 UTC
Created attachment 166078 [details]
screenshot

I can't see icons in
Version: 7.1.0.0.alpha0+
Build ID: 6923b1d527fa86fac8439b881d4ad468b765e915
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 12 Commit Notification 2020-10-06 07:44:45 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-7":

https://git.libreoffice.org/core/commit/cf86ac12bef0f24714a3df4ee88fc2f57d827c00

Restore the fix for tdf#126830

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.